aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-linode
diff options
context:
space:
mode:
authorPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 23:59:33 +0000
committerPo-Chuan Hsieh <sunpoet@FreeBSD.org>2024-04-05 23:59:33 +0000
commit7af7296d3fb84e1bad4247f66dceda3095e66c8f (patch)
treebb4292c6d97e76916e4534489fe2a3cd7772def5 /security/py-certbot-dns-linode
parent2acb682c5a07d8c4ef05100e256d429f76c1caf5 (diff)
downloadports-7af7296d3fb84e1bad4247f66dceda3095e66c8f.tar.gz
ports-7af7296d3fb84e1bad4247f66dceda3095e66c8f.zip
security/py-certbot-dns-linode: Convert to USE_PYTHON=pep517
- Bump PORTREVISION for package change
Diffstat (limited to 'security/py-certbot-dns-linode')
-rw-r--r--security/py-certbot-dns-linode/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/py-certbot-dns-linode/Makefile b/security/py-certbot-dns-linode/Makefile
index cc1ea9edbf76..bfe7dfed4356 100644
--- a/security/py-certbot-dns-linode/Makefile
+++ b/security/py-certbot-dns-linode/Makefile
@@ -1,5 +1,6 @@
PORTNAME= certbot-dns-linode
PORTVERSION= ${ACME_VERSION}
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,13 +14,15 @@ WWW= https://certbot.eff.org/ \
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:devel/py-setuptools@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}wheel>=0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION},1:security/py-certbot@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dns-lexicon>=3.14.1:dns/py-dns-lexicon@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}setuptools>=41.6.0:devel/py-setuptools@${PY_FLAVOR}
USES= python
-USE_PYTHON= autoplist concurrent distutils
+USE_PYTHON= autoplist concurrent pep517
NO_ARCH= yes