aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-luadns
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:42 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:42 +0000
commit44c2106113833d152a30aca4622c0c6c06edfa8c (patch)
tree2f0ae7d750b82795e56e985e51dd13e2b55c5eee /security/py-certbot-dns-luadns
parent6bf5ebd9233605eae503b8c6e820a69c4935782d (diff)
downloadports-44c2106113833d152a30aca4622c0c6c06edfa8c.tar.gz
ports-44c2106113833d152a30aca4622c0c6c06edfa8c.zip
Add py-certbot-dns-luadns, LuaDNS Authenticator plugin for py-certbot.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
Notes
Notes: svn path=/head/; revision=462605
Diffstat (limited to 'security/py-certbot-dns-luadns')
-rw-r--r--security/py-certbot-dns-luadns/Makefile31
-rw-r--r--security/py-certbot-dns-luadns/distinfo3
-rw-r--r--security/py-certbot-dns-luadns/pkg-descr3
3 files changed, 37 insertions, 0 deletions
diff --git a/security/py-certbot-dns-luadns/Makefile b/security/py-certbot-dns-luadns/Makefile
new file mode 100644
index 000000000000..03e150dd4779
--- /dev/null
+++ b/security/py-certbot-dns-luadns/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-luadns
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= LuaDNS Authenticator plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dns-lexicon>0:dns/py-dns-lexicon@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-luadns/distinfo b/security/py-certbot-dns-luadns/distinfo
new file mode 100644
index 000000000000..719c31c90d3e
--- /dev/null
+++ b/security/py-certbot-dns-luadns/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518085957
+SHA256 (certbot-dns-luadns-0.21.1.tar.gz) = e3bf82cfb351357f9ab2e55950981bc8ef88fac0f4bc21d1c9ea1b68ecb90ff6
+SIZE (certbot-dns-luadns-0.21.1.tar.gz) = 11530
diff --git a/security/py-certbot-dns-luadns/pkg-descr b/security/py-certbot-dns-luadns/pkg-descr
new file mode 100644
index 000000000000..4675a97dafb0
--- /dev/null
+++ b/security/py-certbot-dns-luadns/pkg-descr
@@ -0,0 +1,3 @@
+This is the LuaDNS Authenticator plugin for Certbot (security/py-certbot).
+
+WWW: https://github.com/certbot/certbot