aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-ovh
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2018-07-28 02:54:19 +0000
committerMartin Wilke <miwi@FreeBSD.org>2018-07-28 02:54:19 +0000
commit0c52343153b6e8e0f703cf97c7c3101b26b59f76 (patch)
tree18242afb661ff2a635a27776b7c2a3866123d87a /security/py-certbot-dns-ovh
parent4c1d4a4909f564c142c75c358f20f892135cc4f9 (diff)
downloadports-0c52343153b6e8e0f703cf97c7c3101b26b59f76.tar.gz
ports-0c52343153b6e8e0f703cf97c7c3101b26b59f76.zip
This is the OVH DNS Authenticator plugin for Certbot.
WWW: https://github.com/certbot/certbot PR: 229746 Submitted by: tremere@cainites.net Sponsored by: iXsystems Inc.
Notes
Notes: svn path=/head/; revision=475485
Diffstat (limited to 'security/py-certbot-dns-ovh')
-rw-r--r--security/py-certbot-dns-ovh/Makefile33
-rw-r--r--security/py-certbot-dns-ovh/distinfo3
-rw-r--r--security/py-certbot-dns-ovh/pkg-descr3
3 files changed, 39 insertions, 0 deletions
diff --git a/security/py-certbot-dns-ovh/Makefile b/security/py-certbot-dns-ovh/Makefile
new file mode 100644
index 000000000000..670c3244dd54
--- /dev/null
+++ b/security/py-certbot-dns-ovh/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-ovh
+PORTVERSION= ${ACME_VERSION}
+PORTREVISION= 0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= OVH DNS Authenticator plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION},1:security/py-certbot@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dns-lexicon>=2.2.1:dns/py-dns-lexicon@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${PY_FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-ovh/distinfo b/security/py-certbot-dns-ovh/distinfo
new file mode 100644
index 000000000000..ac88c4e397ff
--- /dev/null
+++ b/security/py-certbot-dns-ovh/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1532432404
+SHA256 (certbot-dns-ovh-0.26.1.tar.gz) = f004d4ac45d3f4ddb4b8a73072225530e8164ad1c715bbca90120a56ba02cd85
+SIZE (certbot-dns-ovh-0.26.1.tar.gz) = 11889
diff --git a/security/py-certbot-dns-ovh/pkg-descr b/security/py-certbot-dns-ovh/pkg-descr
new file mode 100644
index 000000000000..14d70580cfb5
--- /dev/null
+++ b/security/py-certbot-dns-ovh/pkg-descr
@@ -0,0 +1,3 @@
+This is the OVH DNS Authenticator plugin for Certbot.
+
+WWW: https://github.com/certbot/certbot