aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-dns-rfc2136
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:51 +0000
committerMathieu Arnold <mat@FreeBSD.org>2018-02-22 14:30:51 +0000
commitccf461f0142939dc84aa5b04c19068a693ca969d (patch)
tree1d52060990fde52626169dc66566163c725b2d01 /security/py-certbot-dns-rfc2136
parent19e80dba7b88bb421dbd47d0f9d06cf33c6d045f (diff)
downloadports-ccf461f0142939dc84aa5b04c19068a693ca969d.tar.gz
ports-ccf461f0142939dc84aa5b04c19068a693ca969d.zip
Add py-certbot-dns-rfc2136, RFC 2136 DNS Authenticator for py-certbot.
Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D14262
Notes
Notes: svn path=/head/; revision=462607
Diffstat (limited to 'security/py-certbot-dns-rfc2136')
-rw-r--r--security/py-certbot-dns-rfc2136/Makefile31
-rw-r--r--security/py-certbot-dns-rfc2136/distinfo3
-rw-r--r--security/py-certbot-dns-rfc2136/pkg-descr3
3 files changed, 37 insertions, 0 deletions
diff --git a/security/py-certbot-dns-rfc2136/Makefile b/security/py-certbot-dns-rfc2136/Makefile
new file mode 100644
index 000000000000..981d86eee01e
--- /dev/null
+++ b/security/py-certbot-dns-rfc2136/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= certbot-dns-rfc2136
+PORTVERSION= ${ACME_VERSION}
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= RFC 2136 DNS Authenticator plugin for Certbot
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION}:security/py-acme@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}certbot>=${ACME_VERSION}:security/py-certbot@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dnspython>0:dns/py-dnspython@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+OPTIONS_DEFINE= DOCS
+
+DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+
+.include "${.CURDIR}/../py-acme/version.mk"
+.include <bsd.port.mk>
diff --git a/security/py-certbot-dns-rfc2136/distinfo b/security/py-certbot-dns-rfc2136/distinfo
new file mode 100644
index 000000000000..13d56a4ab77e
--- /dev/null
+++ b/security/py-certbot-dns-rfc2136/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1518086356
+SHA256 (certbot-dns-rfc2136-0.21.1.tar.gz) = 42f8c9fc91f3ccbdeb8f80594a52db8584e2a65527d63edbd80ac0e725342094
+SIZE (certbot-dns-rfc2136-0.21.1.tar.gz) = 13616
diff --git a/security/py-certbot-dns-rfc2136/pkg-descr b/security/py-certbot-dns-rfc2136/pkg-descr
new file mode 100644
index 000000000000..b55c5dabebdc
--- /dev/null
+++ b/security/py-certbot-dns-rfc2136/pkg-descr
@@ -0,0 +1,3 @@
+This is the RFC 2136 DNS Authenticator plugin for Certbot (security/py-certbot).
+
+WWW: https://github.com/certbot/certbot