aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot-nginx
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-17 18:30:55 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-05-17 18:30:55 +0000
commit9d1aceb118e93cd64540e0ce84cd2d88b31ffd75 (patch)
tree557b78fb89cd109c8072163c6fbd7fd1c161625f /security/py-certbot-nginx
parentab0360361b9141081481bcd1e9faf94907d95a3d (diff)
downloadports-9d1aceb118e93cd64540e0ce84cd2d88b31ffd75.tar.gz
ports-9d1aceb118e93cd64540e0ce84cd2d88b31ffd75.zip
Fix nginx server root path
- Bump PORTREVISION for package change PR: 228294 Reported by: Dhananjay Balan <mail@dbalan.in>
Notes
Notes: svn path=/head/; revision=470243
Diffstat (limited to 'security/py-certbot-nginx')
-rw-r--r--security/py-certbot-nginx/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/security/py-certbot-nginx/Makefile b/security/py-certbot-nginx/Makefile
index 7a4933a53d4e..50a8e3f69a8d 100644
--- a/security/py-certbot-nginx/Makefile
+++ b/security/py-certbot-nginx/Makefile
@@ -2,7 +2,7 @@
PORTNAME= certbot-nginx
PORTVERSION= ${ACME_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -30,5 +30,8 @@ OPTIONS_DEFINE= DOCS
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sphinx_rtd_theme>0:textproc/py-sphinx_rtd_theme@${FLAVOR}
+post-patch:
+ @${REINPLACE_CMD} -e '/server_root=/ s|/etc/nginx|${LOCALBASE}&|' ${WRKSRC}/certbot_nginx/constants.py
+
.include "${.CURDIR}/../py-acme/version.mk"
.include <bsd.port.mk>