aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-29 06:58:22 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2019-04-29 06:58:22 +0000
commit01a3c0f5078a18ad8232ef31f8e756f6c76134aa (patch)
tree321ec46a7e60695a06e428e1d8a486d923ac63ad /security/py-certbot
parent2a6ce92e33bdddda88f08c77958a3009ef0b2887 (diff)
downloadports-01a3c0f5078a18ad8232ef31f8e756f6c76134aa.tar.gz
ports-01a3c0f5078a18ad8232ef31f8e756f6c76134aa.zip
Update to 0.33.1
Notes
Notes: svn path=/head/; revision=500391
Diffstat (limited to 'security/py-certbot')
-rw-r--r--security/py-certbot/Makefile5
-rw-r--r--security/py-certbot/distinfo6
-rw-r--r--security/py-certbot/files/patch-certbot-compat-misc.py (renamed from security/py-certbot/files/patch-certbot_compat.py)8
-rw-r--r--security/py-certbot/files/patch-setup.py12
4 files changed, 15 insertions, 16 deletions
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index d26e1ac06bba..d09847cee2cd 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -3,7 +3,6 @@
PORTNAME= certbot
PORTVERSION= ${ACME_VERSION}
-PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
@@ -19,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${P
${PYTHON_PKGNAMEPREFIX}configargparse>=0.9.3:devel/py-configargparse@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}configobj>0:devel/py-configobj@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cryptography>=1.2.3:security/py-cryptography@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}josepy>=0:security/py-josepy@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}josepy>=1.1.0:security/py-josepy@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}parsedatetime>=1.3:devel/py-parsedatetime@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339@${PY_FLAVOR} \
@@ -36,7 +35,7 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
post-patch:
- @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/certbot/compat.py
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/certbot/compat/misc.py
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
diff --git a/security/py-certbot/distinfo b/security/py-certbot/distinfo
index fc8c15c496b7..49461f8156ca 100644
--- a/security/py-certbot/distinfo
+++ b/security/py-certbot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1549641992
-SHA256 (certbot-0.31.0.tar.gz) = 0c3196f80a102c0f9d82d566ba859efe3b70e9ed4670520224c844fafd930473
-SIZE (certbot-0.31.0.tar.gz) = 336579
+TIMESTAMP = 1556374442
+SHA256 (certbot-0.33.1.tar.gz) = d5203f32c50f3ec5a32df97e4affddbcd288a569678ecb5669adda21cd5ac3d9
+SIZE (certbot-0.33.1.tar.gz) = 342753
diff --git a/security/py-certbot/files/patch-certbot_compat.py b/security/py-certbot/files/patch-certbot-compat-misc.py
index bc6880e90ef2..a90c68662a2b 100644
--- a/security/py-certbot/files/patch-certbot_compat.py
+++ b/security/py-certbot/files/patch-certbot-compat-misc.py
@@ -2,9 +2,9 @@
# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=233909
# TODO: Upstream
---- certbot/compat.py.orig 2019-02-07 21:20:29 UTC
-+++ certbot/compat.py
-@@ -187,6 +187,11 @@ LINUX_DEFAULT_FOLDERS = {
+--- certbot/compat/misc.py.orig 2019-04-04 22:02:08 UTC
++++ certbot/compat/misc.py
+@@ -129,6 +129,11 @@ LINUX_DEFAULT_FOLDERS = {
'work': '/var/lib/letsencrypt',
'logs': '/var/log/letsencrypt',
}
@@ -16,7 +16,7 @@
def get_default_folder(folder_type):
-@@ -200,8 +205,13 @@ def get_default_folder(folder_type):
+@@ -142,8 +147,13 @@ def get_default_folder(folder_type):
"""
if os.name != 'nt':
diff --git a/security/py-certbot/files/patch-setup.py b/security/py-certbot/files/patch-setup.py
index 4b750227960f..226b79700835 100644
--- a/security/py-certbot/files/patch-setup.py
+++ b/security/py-certbot/files/patch-setup.py
@@ -1,14 +1,14 @@
---- setup.py.orig 2019-02-07 21:20:31 UTC
+--- setup.py.orig 2019-04-04 22:02:09 UTC
+++ setup.py
-@@ -39,7 +39,6 @@ install_requires = [
- 'configobj',
- 'cryptography>=1.2.3', # load_pem_x509_certificate
- 'josepy',
+@@ -43,7 +43,6 @@ install_requires = [
+ # 1.1.0+ is required to avoid the warnings described at
+ # https://github.com/certbot/josepy/issues/13.
+ 'josepy>=1.1.0',
- 'mock',
'parsedatetime>=1.3', # Calendar.parseDT
'pyrfc3339',
'pytz',
-@@ -53,6 +52,7 @@ dev_extras = [
+@@ -57,6 +56,7 @@ dev_extras = [
'astroid==1.3.5',
'coverage',
'ipdb',