aboutsummaryrefslogtreecommitdiff
path: root/security/py-certbot
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2021-03-07 16:51:45 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2021-03-07 16:51:45 +0000
commit3b1494205f704e4215a3299fa5432551eea3d5fe (patch)
tree263b1ca95727fb8f2302dcb31e4fe6610d868bcd /security/py-certbot
parentf2499eec5ae60bcd0ce31852e0d518ca1c143e44 (diff)
downloadports-3b1494205f704e4215a3299fa5432551eea3d5fe.tar.gz
ports-3b1494205f704e4215a3299fa5432551eea3d5fe.zip
security/py-[acme|certbot]: Update to 1.13.0
Changelog: https://github.com/certbot/certbot/blob/v1.13.0/certbot/CHANGELOG.md PR: 253224 Submitted by: Yasuhiro KIMURA <yasu@utahime.org> Approved by: python (with hat)
Notes
Notes: svn path=/head/; revision=567578
Diffstat (limited to 'security/py-certbot')
-rw-r--r--security/py-certbot/Makefile4
-rw-r--r--security/py-certbot/distinfo6
-rw-r--r--security/py-certbot/files/patch-certbot-compat-misc.py6
-rw-r--r--security/py-certbot/files/patch-tests_cli__test.py8
4 files changed, 11 insertions, 13 deletions
diff --git a/security/py-certbot/Makefile b/security/py-certbot/Makefile
index 3b7af0d4c85e..f167b38a2483 100644
--- a/security/py-certbot/Makefile
+++ b/security/py-certbot/Makefile
@@ -24,10 +24,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}acme>=${ACME_VERSION},1:security/py-acme@${P
${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyrfc3339>0:devel/py-pyrfc3339@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}zope.component>0:devel/py-zope.component@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>0:devel/py-zope.interface@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest@${PY_FLAVOR}
USES= python:3.6+
diff --git a/security/py-certbot/distinfo b/security/py-certbot/distinfo
index d39a7bbc103b..85d38ce38b2b 100644
--- a/security/py-certbot/distinfo
+++ b/security/py-certbot/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1609974390
-SHA256 (certbot-1.11.0.tar.gz) = 6b0ce04e55379aff0a47f873fa05c084538ad0f4a9b79f33108dbb0a7a668b43
-SIZE (certbot-1.11.0.tar.gz) = 391257
+TIMESTAMP = 1615124931
+SHA256 (certbot-1.13.0.tar.gz) = 64cf41b57df7667d9d849fcaa9031a4f151788246733d1f4c3f37a5aa5e2f458
+SIZE (certbot-1.13.0.tar.gz) = 393163
diff --git a/security/py-certbot/files/patch-certbot-compat-misc.py b/security/py-certbot/files/patch-certbot-compat-misc.py
index e9c60c47692c..c104a34cf796 100644
--- a/security/py-certbot/files/patch-certbot-compat-misc.py
+++ b/security/py-certbot/files/patch-certbot-compat-misc.py
@@ -4,9 +4,9 @@
# https://github.com/certbot/certbot/pull/7056
# TODO: Upstream
---- certbot/compat/misc.py.orig 2020-01-14 18:41:31 UTC
+--- certbot/compat/misc.py.orig 2021-03-02 21:37:04 UTC
+++ certbot/compat/misc.py
-@@ -74,6 +74,11 @@ LINUX_DEFAULT_FOLDERS = {
+@@ -79,6 +79,11 @@ LINUX_DEFAULT_FOLDERS = {
'work': '/var/lib/letsencrypt',
'logs': '/var/log/letsencrypt',
}
@@ -18,7 +18,7 @@
def get_default_folder(folder_type):
-@@ -88,8 +93,13 @@ def get_default_folder(folder_type):
+@@ -93,8 +98,13 @@ def get_default_folder(folder_type):
"""
if os.name != 'nt':
diff --git a/security/py-certbot/files/patch-tests_cli__test.py b/security/py-certbot/files/patch-tests_cli__test.py
index e3316a6b7984..f285dc6c2054 100644
--- a/security/py-certbot/files/patch-tests_cli__test.py
+++ b/security/py-certbot/files/patch-tests_cli__test.py
@@ -1,16 +1,16 @@
# See files/patch-certbot-compat-misc.py
---- tests/cli_test.py.orig 2020-03-03 20:36:36 UTC
+--- tests/cli_test.py.orig 2021-03-02 21:37:04 UTC
+++ tests/cli_test.py
@@ -1,6 +1,7 @@
"""Tests for certbot._internal.cli."""
import argparse
import copy
+import sys
+ from importlib import reload as reload_module
+ import io
import tempfile
- import unittest
-
-@@ -58,9 +59,14 @@ class FlagDefaultTest(unittest.TestCase):
+@@ -62,9 +63,14 @@ class FlagDefaultTest(unittest.TestCase):
def test_default_directories(self):
if os.name != 'nt':