aboutsummaryrefslogtreecommitdiff
path: root/security/py-certstream
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-12-23 13:12:08 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-12-23 13:12:08 +0000
commit6938310ec8803fd1243a6d777dde7d6481348352 (patch)
tree5b7b2e6423941426ece112a8ff95d5ce9f39d5d0 /security/py-certstream
parentd7fe9aeefb00745dbb9dce23a5413d4becec5619 (diff)
downloadports-6938310ec8803fd1243a6d777dde7d6481348352.tar.gz
ports-6938310ec8803fd1243a6d777dde7d6481348352.zip
Notes
Diffstat (limited to 'security/py-certstream')
-rw-r--r--security/py-certstream/Makefile6
-rw-r--r--security/py-certstream/distinfo6
-rw-r--r--security/py-certstream/files/patch-certstream_core.py32
3 files changed, 4 insertions, 40 deletions
diff --git a/security/py-certstream/Makefile b/security/py-certstream/Makefile
index a7689f1e3978..b31df4ac245f 100644
--- a/security/py-certstream/Makefile
+++ b/security/py-certstream/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= certstream
-PORTVERSION= 1.10
-PORTREVISION= 2
+PORTVERSION= 1.11
CATEGORIES= security www python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -22,7 +21,4 @@ USE_PYTHON= distutils autoplist concurrent
NO_ARCH= yes
-post-patch:
- @${REINPLACE_CMD} 's,==.*,,' ${WRKSRC}/requirements.txt
-
.include <bsd.port.mk>
diff --git a/security/py-certstream/distinfo b/security/py-certstream/distinfo
index c79a471e15f2..f228633b79bb 100644
--- a/security/py-certstream/distinfo
+++ b/security/py-certstream/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1537604749
-SHA256 (certstream-1.10.tar.gz) = 566d59ceda3371ce5093fa985d6b6b5f11413cb3e4afa25311a890b524695548
-SIZE (certstream-1.10.tar.gz) = 9514
+TIMESTAMP = 1577106276
+SHA256 (certstream-1.11.tar.gz) = 660fdcb76c12a66a1600a0ef63701a78462f48660b6e8584002989b7d64e3a6f
+SIZE (certstream-1.11.tar.gz) = 9544
diff --git a/security/py-certstream/files/patch-certstream_core.py b/security/py-certstream/files/patch-certstream_core.py
deleted file mode 100644
index 5c291abe5c3a..000000000000
--- a/security/py-certstream/files/patch-certstream_core.py
+++ /dev/null
@@ -1,32 +0,0 @@
---- certstream/core.py.orig 2018-03-02 11:20:56 UTC
-+++ certstream/core.py
-@@ -27,12 +27,12 @@ class CertStreamClient(WebSocketApp):
- on_error=self._on_error,
- )
-
-- def _on_open(self, instance):
-+ def _on_open(self):
- logging.info("Connection established to CertStream! Listening for events...")
- if self.on_open_handler:
-- self.on_open_handler(instance)
-+ self.on_open_handler()
-
-- def _on_message(self, _, message):
-+ def _on_message(self, message):
- frame = json.loads(message)
-
- if frame.get('message_type', None) == "heartbeat" and self.skip_heartbeats:
-@@ -40,11 +40,11 @@ class CertStreamClient(WebSocketApp):
-
- self.message_callback(frame, self._context)
-
-- def _on_error(self, instance, ex):
-+ def _on_error(self, ex):
- if type(ex) == KeyboardInterrupt:
- raise
- if self.on_error_handler:
-- self.on_error_handler(instance, ex)
-+ self.on_error_handler(ex)
- logging.error("Error connecting to CertStream - {} - Sleeping for a few seconds and trying again...".format(ex))
-
- def listen_for_events(message_callback, url, skip_heartbeats=True, setup_logger=True, on_open=None, on_error=None, **kwargs):