aboutsummaryrefslogtreecommitdiff
path: root/security/py-coincurve
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-08-03 16:34:27 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-08-03 16:34:27 +0000
commit2642ced69926ed6d4092efbe632bf5abbf2235be (patch)
treed8d341ce4240ac34e51a4ddb0668e439646091d2 /security/py-coincurve
parent21e16f48cd0e13b999c6054e5f13b0f03447d384 (diff)
downloadports-2642ced69926ed6d4092efbe632bf5abbf2235be.tar.gz
ports-2642ced69926ed6d4092efbe632bf5abbf2235be.zip
New port: security/py-coincurve: Cross-platform Python CFFI bindings for libsecp256k1
Notes
Notes: svn path=/head/; revision=544082
Diffstat (limited to 'security/py-coincurve')
-rw-r--r--security/py-coincurve/Makefile27
-rw-r--r--security/py-coincurve/distinfo3
-rw-r--r--security/py-coincurve/pkg-descr5
3 files changed, 35 insertions, 0 deletions
diff --git a/security/py-coincurve/Makefile b/security/py-coincurve/Makefile
new file mode 100644
index 000000000000..b5dede1db490
--- /dev/null
+++ b/security/py-coincurve/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= coincurve
+DISTVERSION= 13.0.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Cross-platform Python CFFI bindings for libsecp256k1
+
+LICENSE= MIT APACHE20
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}requests>0:www/py-requests@${PY_FLAVOR} \
+ gmake:devel/gmake
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>0:devel/py-asn1crypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cffi>0:devel/py-cffi@${PY_FLAVOR}
+
+USES= pkgconfig python
+USE_PYTHON= distutils autoplist
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/coincurve/_libsecp256k1.so
+
+.include <bsd.port.mk>
diff --git a/security/py-coincurve/distinfo b/security/py-coincurve/distinfo
new file mode 100644
index 000000000000..98424103d775
--- /dev/null
+++ b/security/py-coincurve/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1596471505
+SHA256 (coincurve-13.0.0.tar.gz) = 9985627dc0c81fe98c3d2e97412801e9726d6110249317a2775cf365f0ba0df5
+SIZE (coincurve-13.0.0.tar.gz) = 961637
diff --git a/security/py-coincurve/pkg-descr b/security/py-coincurve/pkg-descr
new file mode 100644
index 000000000000..a764bdbfd40a
--- /dev/null
+++ b/security/py-coincurve/pkg-descr
@@ -0,0 +1,5 @@
+The coincurve python library provides well-tested Python CFFI bindings for
+libsecp256k1, the heavily optimized C library used by Bitcoin Core for
+operations on elliptic curve secp256k1.
+
+WWW: https://github.com/ofek/coincurve