aboutsummaryrefslogtreecommitdiff
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorSteve Wills <swills@FreeBSD.org>2016-08-12 16:58:34 +0000
committerSteve Wills <swills@FreeBSD.org>2016-08-12 16:58:34 +0000
commit1b0fe1b41fb3b1d36203ef84755407e81b196448 (patch)
tree39ed22e8a367717d87b07bf8f04c5f7f65e47c81 /security/py-cryptography
parent54c82eb9259e98566842a6b7487f6cf663243845 (diff)
downloadports-1b0fe1b41fb3b1d36203ef84755407e81b196448.tar.gz
ports-1b0fe1b41fb3b1d36203ef84755407e81b196448.zip
security/py-cryptography: update to 1.4
PR: 210484 Approved by: koobs (maintainer)
Notes
Notes: svn path=/head/; revision=420137
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile4
-rw-r--r--security/py-cryptography/distinfo5
-rw-r--r--security/py-cryptography/files/patch-src___cffi__src_build__openssl.py32
-rw-r--r--security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py4
4 files changed, 7 insertions, 38 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 0847622c2f12..f1df74e24062 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cryptography
-PORTVERSION= 1.3.1
+PORTVERSION= 1.4
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,7 +13,7 @@ COMMENT= Cryptographic recipes and primitives for Python developers
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.4.1:devel/py-cffi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:devel/py-six \
${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.8:devel/py-pyasn1 \
${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:devel/py-cffi \
diff --git a/security/py-cryptography/distinfo b/security/py-cryptography/distinfo
index 7efae487da7d..e2d988b9a4ee 100644
--- a/security/py-cryptography/distinfo
+++ b/security/py-cryptography/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cryptography-1.3.1.tar.gz) = b4b36175e0f95ddc88435c26dbe3397edce48e2ff5fe41d504cdb3beddcd53e2
-SIZE (cryptography-1.3.1.tar.gz) = 383852
+TIMESTAMP = 1471010865
+SHA256 (cryptography-1.4.tar.gz) = bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128
+SIZE (cryptography-1.4.tar.gz) = 399707
diff --git a/security/py-cryptography/files/patch-src___cffi__src_build__openssl.py b/security/py-cryptography/files/patch-src___cffi__src_build__openssl.py
deleted file mode 100644
index 121180e065fe..000000000000
--- a/security/py-cryptography/files/patch-src___cffi__src_build__openssl.py
+++ /dev/null
@@ -1,32 +0,0 @@
-Use upstream post-1.3.1 patch for LibreSSL
-
-From 1e88d741f6e15d9170466a08dfe85f28b12c7623 Mon Sep 17 00:00:00 2001
-From: Paul Kehrer <paul.l.kehrer@gmail.com>
-Date: Mon, 28 Mar 2016 22:00:00 -0400
-Subject: [PATCH] fix libressl breakage reported in #2858
-
----
- src/_cffi_src/build_openssl.py | 9 ++++++++-
- 1 file changed, 8 insertions(+), 1 deletion(-)
-
-diff --git a/src/_cffi_src/build_openssl.py b/src/_cffi_src/build_openssl.py
-index 2ff28d7..3f92529 100644
---- src/_cffi_src/build_openssl.py.orig
-+++ src/_cffi_src/build_openssl.py
-@@ -38,8 +38,15 @@ def _osx_libraries(build_static):
-
-
- _PRE_INCLUDE = """
-+#include <openssl/opensslv.h>
-+/*
-+ LibreSSL removed e_os2.h from the public headers so we'll only include it
-+ if we're using vanilla OpenSSL.
-+*/
-+#if !defined(LIBRESSL_VERSION_NUMBER)
- #include <openssl/e_os2.h>
--#if defined(OPENSSL_SYS_WINDOWS)
-+#endif
-+#if defined(OPENSSL_SYS_WINDOWS) || defined(_WIN32)
- #include <windows.h>
- #endif
- """
diff --git a/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py b/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py
index 48ddafc0b7b5..82f812e4c62b 100644
--- a/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py
+++ b/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py
@@ -1,6 +1,6 @@
---- src/_cffi_src/openssl/ec.py.orig 2015-09-27 13:51:07 UTC
+--- src/_cffi_src/openssl/ec.py.orig 2016-06-04 17:06:01 UTC
+++ src/_cffi_src/openssl/ec.py
-@@ -396,7 +396,8 @@ EC_GROUP *(*EC_GROUP_new_curve_GF2m)(
+@@ -371,7 +371,8 @@ EC_GROUP *(*EC_GROUP_new_curve_GF2m)(
static const long Cryptography_HAS_EC2M = 1;
#endif