aboutsummaryrefslogtreecommitdiff
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /security/py-cryptography
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile29
1 files changed, 10 insertions, 19 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 9fb790f7122b..c1347cb2334d 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -15,35 +15,26 @@ LICENSE_COMB= dual
LICENSE_FILE_APACHE20= ${WRKSRC}/LICENSE.APACHE
LICENSE_FILE_BSD3CLAUSE= ${WRKSRC}/LICENSE.BSD
-BUILD_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}cffi>=1.7:devel/py-cffi
-RUN_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:devel/py-six \
- ${PYTHON_PKGNAMEPREFIX}asn1crypto>=0.21.0:devel/py-asn1crypto \
- ${PYTHON_PKGNAMEPREFIX}cffi>=1.7:devel/py-cffi \
- ${PYTHON_PKGNAMEPREFIX}idna>=2.1:dns/py-idna
-TEST_DEPENDS?= ${PYTHON_PKGNAMEPREFIX}pytest>=2.9.0:devel/py-pytest \
- ${PYTHON_PKGNAMEPREFIX}iso8601>0:devel/py-iso8601
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.7:devel/py-cffi@${FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:devel/py-six@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}asn1crypto>=0.21.0:devel/py-asn1crypto@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cffi>=1.7:devel/py-cffi@${FLAVOR} \
+ ${PY_ENUM34} ${PY_IPADDRESS} \
+ ${PYTHON_PKGNAMEPREFIX}idna>=2.1:dns/py-idna@${FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=2.9.0:devel/py-pytest@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}iso8601>0:devel/py-iso8601@${FLAVOR}
# Python 2.7, 3.4-3.6
-USES?= python ssl
+USES= python ssl
USE_PYTHON= autoplist concurrent distutils
CFLAGS+= -I${OPENSSLINC}
LDFLAGS+= -L${OPENSSLLIB}
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipaddress>0:net/py-ipaddress
-.endif
-
-.if ${PYTHON_REL} < 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:devel/py-enum34
-.endif
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cryptography/hazmat/bindings/*.so
do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>