aboutsummaryrefslogtreecommitdiff
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2015-11-02 16:39:53 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2015-11-02 16:39:53 +0000
commita8fe7b23c5819dfa8ed3ec35417b1364013afef6 (patch)
tree717f56a68173001c7a96a932ae8b48b0d9700ca9 /security/py-cryptography
parentf20b2099a625db1f0de5ea4080550dd39d0fec0d (diff)
downloadports-a8fe7b23c5819dfa8ed3ec35417b1364013afef6.tar.gz
ports-a8fe7b23c5819dfa8ed3ec35417b1364013afef6.zip
security/py-cryptography: Add missing run-time dependencies
Add py-idna and conditionally (For Python < 3.3) py-ipaddress to RUN_DEPENDS While I'm here: - Update minimum versions requirement for py-cffi - Update test target since the framework supports TEST_DEPENDS et al. Noticed by: brnrd
Notes
Notes: svn path=/head/; revision=400661
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index 058afda3e8b5..47293b31c864 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cryptography
PORTVERSION= 1.0.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,10 +14,11 @@ COMMENT= Cryptographic recipes and primitives for Python developers
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=0.8:${PORTSDIR}/devel/py-cffi
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:${PORTSDIR}/devel/py-cffi
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:${PORTSDIR}/devel/py-six \
${PYTHON_PKGNAMEPREFIX}asn1>=0.1.8:${PORTSDIR}/devel/py-asn1 \
- ${PYTHON_PKGNAMEPREFIX}cffi>=0.8:${PORTSDIR}/devel/py-cffi
+ ${PYTHON_PKGNAMEPREFIX}cffi>=1.1.0:${PORTSDIR}/devel/py-cffi \
+ ${PYTHON_PKGNAMEPREFIX}idna>=2.0:${PORTSDIR}/dns/py-idna
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:${PORTSDIR}/devel/py-pytest \
${PYTHON_PKGNAMEPREFIX}iso8601>0:${PORTSDIR}/devel/py-iso8601
@@ -30,6 +31,10 @@ LDFLAGS+= -L${OPENSSLLIB}
.include <bsd.port.pre.mk>
+.if ${PYTHON_REL} < 3300
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}ipaddress>0:${PORTSDIR}/net/py-ipaddress
+.endif
+
.if ${PYTHON_REL} < 3400
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:${PORTSDIR}/devel/py-enum34
.endif
@@ -37,7 +42,7 @@ RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>0:${PORTSDIR}/devel/py-enum34
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/cryptography/hazmat/bindings/*.so
-regression-test: build
+do-test:
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.post.mk>