aboutsummaryrefslogtreecommitdiff
path: root/security/py-cryptography
diff options
context:
space:
mode:
authorMark Felder <feld@FreeBSD.org>2016-12-04 22:18:51 +0000
committerMark Felder <feld@FreeBSD.org>2016-12-04 22:18:51 +0000
commitf999f2ff7ef6f4b7e5133c52038f127e3f28f419 (patch)
tree054dfce1d5bf16a4df83b70e853f16cf8065dcc5 /security/py-cryptography
parentdfca695d966f988b011e5b016ab37b5af002d054 (diff)
downloadports-f999f2ff7ef6f4b7e5133c52038f127e3f28f419.tar.gz
ports-f999f2ff7ef6f4b7e5133c52038f127e3f28f419.zip
security/py-cryptography: Update to 1.6
Changelog: https://github.com/pyca/cryptography/blob/master/CHANGELOG.rst PR: 214915 Approved by: ports-secteam (with hat) MFH: 2016Q4 Security: CVE-2016-9243
Notes
Notes: svn path=/head/; revision=427810
Diffstat (limited to 'security/py-cryptography')
-rw-r--r--security/py-cryptography/Makefile5
-rw-r--r--security/py-cryptography/distinfo6
-rw-r--r--security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py12
3 files changed, 5 insertions, 18 deletions
diff --git a/security/py-cryptography/Makefile b/security/py-cryptography/Makefile
index f1df74e24062..9fc184a00ef1 100644
--- a/security/py-cryptography/Makefile
+++ b/security/py-cryptography/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cryptography
-PORTVERSION= 1.4
+PORTVERSION= 1.6
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -21,8 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.4.1:devel/py-six \
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest \
${PYTHON_PKGNAMEPREFIX}iso8601>0:devel/py-iso8601
-USES= python
-USE_OPENSSL= yes
+USES= python ssl
USE_PYTHON= autoplist distutils
CFLAGS+= -I${OPENSSLINC}
diff --git a/security/py-cryptography/distinfo b/security/py-cryptography/distinfo
index e2d988b9a4ee..745ba5ed04c9 100644
--- a/security/py-cryptography/distinfo
+++ b/security/py-cryptography/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1471010865
-SHA256 (cryptography-1.4.tar.gz) = bb149540ed90c4b2171bf694fe6991d6331bc149ae623c8ff419324f4222d128
-SIZE (cryptography-1.4.tar.gz) = 399707
+TIMESTAMP = 1480367088
+SHA256 (cryptography-1.6.tar.gz) = 4d0d86d2c8d3fc89133c3fa0d164a688a458b6663ab6fa965c80d6c2cdaf9b3f
+SIZE (cryptography-1.6.tar.gz) = 410073
diff --git a/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py b/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py
deleted file mode 100644
index 82f812e4c62b..000000000000
--- a/security/py-cryptography/files/patch-src___cffi__src_openssl_ec.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- src/_cffi_src/openssl/ec.py.orig 2016-06-04 17:06:01 UTC
-+++ src/_cffi_src/openssl/ec.py
-@@ -371,7 +371,8 @@ EC_GROUP *(*EC_GROUP_new_curve_GF2m)(
- static const long Cryptography_HAS_EC2M = 1;
- #endif
-
--#if defined(OPENSSL_NO_EC) || OPENSSL_VERSION_NUMBER < 0x1000200f || \
-+#if defined(OPENSSL_NO_EC) || \
-+ OPENSSL_VERSION_NUMBER < 0x1000200f && !defined(LIBRESSL_VERSION_NUMBER) || \
- defined(LIBRESSL_VERSION_NUMBER) && LIBRESSL_VERSION_NUMBER < 0x20020002L
- static const long Cryptography_HAS_EC_1_0_2 = 0;
- const char *(*EC_curve_nid2nist)(int) = NULL;