aboutsummaryrefslogtreecommitdiff
path: root/security/py-cybox
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2017-01-22 13:40:05 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2017-01-22 13:40:05 +0000
commitf40da9a46ca16a11267d8bda44c0604339048b1b (patch)
tree5825ccfe971f8c96319b9477495582b75510e8b1 /security/py-cybox
parent6f24bd3ecadf5fe1a645d1f711a7da1584e70da3 (diff)
downloadports-f40da9a46ca16a11267d8bda44c0604339048b1b.tar.gz
ports-f40da9a46ca16a11267d8bda44c0604339048b1b.zip
- Update to 2.1.0.13
- This version works fine with python3 - Add do-test target
Notes
Notes: svn path=/head/; revision=432132
Diffstat (limited to 'security/py-cybox')
-rw-r--r--security/py-cybox/Makefile16
-rw-r--r--security/py-cybox/distinfo5
2 files changed, 15 insertions, 6 deletions
diff --git a/security/py-cybox/Makefile b/security/py-cybox/Makefile
index 4d2895b9a3d5..48f31c05c1dd 100644
--- a/security/py-cybox/Makefile
+++ b/security/py-cybox/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cybox
-PORTVERSION= 2.1.0.12
+PORTVERSION= 2.1.0.13
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,9 +14,12 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil \
- ${PYTHON_PKGNAMEPREFIX}lxml>=3.1:devel/py-lxml
+ ${PYTHON_PKGNAMEPREFIX}lxml>=2.2.3:devel/py-lxml \
+ ${PYTHON_PKGNAMEPREFIX}mixbox>=0.0.13:security/py-mixbox
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=0:devel/py-nose
-USES= python:2
+NO_ARCH= yes
+USES= python
USE_PYTHON= distutils autoplist
PORTDOCS= README.rst
@@ -24,10 +27,15 @@ PORTEXAMPLES= *
OPTIONS_DEFINE= DOCS EXAMPLES
-post-install:
+do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+
+do-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${STAGEDIR}${EXAMPLESDIR}
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} nosetests-${PYTHON_VER})
+
.include <bsd.port.mk>
diff --git a/security/py-cybox/distinfo b/security/py-cybox/distinfo
index 074369da4dc1..eef7eac4aa57 100644
--- a/security/py-cybox/distinfo
+++ b/security/py-cybox/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cybox-2.1.0.12.tar.gz) = fb5e12580211cea37fdedfe85017d3e1430f7340d2f1f18452b6c1794ca8b6f4
-SIZE (cybox-2.1.0.12.tar.gz) = 482625
+TIMESTAMP = 1485089735
+SHA256 (cybox-2.1.0.13.tar.gz) = daa2456db3c7f211cb92c567970d7d9b95b068cd2efbf04e5bbbcecf5c3ffdb6
+SIZE (cybox-2.1.0.13.tar.gz) = 478316