aboutsummaryrefslogtreecommitdiff
path: root/security/py-dfvfs/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2019-11-24 13:21:03 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2019-11-24 13:21:03 +0000
commitd845d018d9a7b934413eb4f1b03a614e93ba594b (patch)
tree42faaee2c070cbdce2415d8a89d77f3c2e0a3911 /security/py-dfvfs/Makefile
parent8528b12a7adf2a40f31c5ddf3e8ab0c3be831763 (diff)
downloadports-d845d018d9a7b934413eb4f1b03a614e93ba594b.tar.gz
ports-d845d018d9a7b934413eb4f1b03a614e93ba594b.zip
Notes
Diffstat (limited to 'security/py-dfvfs/Makefile')
-rw-r--r--security/py-dfvfs/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/security/py-dfvfs/Makefile b/security/py-dfvfs/Makefile
index de0f1e2ea4d7..93c01cfbff9d 100644
--- a/security/py-dfvfs/Makefile
+++ b/security/py-dfvfs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dfvfs
-PORTVERSION= 20190609
+PORTVERSION= 20190902
CATEGORIES= security devel python
MASTER_SITES= https://github.com/log2timeline/dfvfs/releases/download/${PORTVERSION}/ \
LOCAL/antoine
@@ -33,23 +33,15 @@ RUN_DEPENDS= libbde>=a:devel/libbde \
${PYTHON_PKGNAMEPREFIX}pycrypto>=0:security/py-pycrypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pytsk>=0:sysutils/py-pytsk@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>0:devel/py-mock@${PY_FLAVOR} \
+ ca_root_nss>=0:security/ca_root_nss
-USES= python
+USES= python:3.5+
USE_LOCALE= en_US.UTF-8
USE_PYTHON= distutils autoplist concurrent
NO_ARCH= yes
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3300
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}backports.lzma>=0:archivers/py-backports.lzma@${PY_FLAVOR}
-TEST_ENV= ${MAKE_ENV} PYTHONHTTPSVERIFY=0
-.else
-TEST_DEPENDS+= ca_root_nss>=0:security/ca_root_nss
-.endif
-
post-patch:
${REINPLACE_CMD} "s,share/doc/dfvfs,${DOCSDIR_REL}," ${WRKSRC}/setup.py
@@ -57,4 +49,4 @@ do-test:
@${TOUCH} ${TEST_WRKSRC}/utils/__init__.py
@(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} run_tests.py)
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>