aboutsummaryrefslogtreecommitdiff
path: root/security/py-dfvfs
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2020-02-29 20:44:13 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2020-02-29 20:44:13 +0000
commitd13d0a64a08056e7d8a0626e353b6b3e8ec5fe1c (patch)
treed93c0972dbd6dd63955c112b828b107d0305b95d /security/py-dfvfs
parentf5e6d043f7e6ebaa1c2399141fe3e1b37b5787a8 (diff)
downloadports-d13d0a64a08056e7d8a0626e353b6b3e8ec5fe1c.tar.gz
ports-d13d0a64a08056e7d8a0626e353b6b3e8ec5fe1c.zip
Update to 20200211
Notes
Notes: svn path=/head/; revision=527469
Diffstat (limited to 'security/py-dfvfs')
-rw-r--r--security/py-dfvfs/Makefile3
-rw-r--r--security/py-dfvfs/distinfo6
-rw-r--r--security/py-dfvfs/files/patch-dfvfs_vfs_tsk__file__entry.py11
3 files changed, 5 insertions, 15 deletions
diff --git a/security/py-dfvfs/Makefile b/security/py-dfvfs/Makefile
index 4ad1f903aedb..6d388f7bda4f 100644
--- a/security/py-dfvfs/Makefile
+++ b/security/py-dfvfs/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= dfvfs
-PORTVERSION= 20200121
+PORTVERSION= 20200211
CATEGORIES= security devel python
MASTER_SITES= https://github.com/log2timeline/dfvfs/releases/download/${PORTVERSION}/ \
LOCAL/antoine
@@ -20,6 +20,7 @@ RUN_DEPENDS= libbde>=a:devel/libbde \
libfsntfs>=e:devel/libfsntfs \
libfvde>=0:sysutils/libfvde \
libfwnt>=e:devel/libfwnt \
+ libluksde>=e:devel/libluksde \
libqcow>=a:devel/libqcow \
libsigscan>=e:devel/libsigscan \
libsmdev>=a:devel/libsmdev \
diff --git a/security/py-dfvfs/distinfo b/security/py-dfvfs/distinfo
index 8d52c103e64c..35f0280dd032 100644
--- a/security/py-dfvfs/distinfo
+++ b/security/py-dfvfs/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1579697011
-SHA256 (dfvfs-20200121.tar.gz) = 33abd173cee972c6da784ba018b24080c03c2ed9bc96429cdd4ba231fccdc16b
-SIZE (dfvfs-20200121.tar.gz) = 78161691
+TIMESTAMP = 1581500139
+SHA256 (dfvfs-20200211.tar.gz) = 52a673d73a79be080714f3b175d7c8a5292f328846650c1c4ba584f5a23d4a6a
+SIZE (dfvfs-20200211.tar.gz) = 79510175
diff --git a/security/py-dfvfs/files/patch-dfvfs_vfs_tsk__file__entry.py b/security/py-dfvfs/files/patch-dfvfs_vfs_tsk__file__entry.py
deleted file mode 100644
index 4a90f60d4d69..000000000000
--- a/security/py-dfvfs/files/patch-dfvfs_vfs_tsk__file__entry.py
+++ /dev/null
@@ -1,11 +0,0 @@
---- dfvfs/vfs/tsk_file_entry.py.orig 2019-06-08 17:38:10 UTC
-+++ dfvfs/vfs/tsk_file_entry.py
-@@ -105,7 +105,7 @@ class TSKTime(dfdatetime_interface.DateTimeValues):
- microseconds = date_time_values.get('microseconds', 0)
-
- self._timestamp = self._GetNumberOfSecondsFromElements(
-- year, month, day_of_month, hours, minutes, seconds)
-+ year, month, day_of_month, hours, minutes, seconds, None)
- self.fraction_of_second = microseconds
-
- if pytsk3.TSK_VERSION_NUM >= 0x040200ff: