aboutsummaryrefslogtreecommitdiff
path: root/security/py-ecdsa
diff options
context:
space:
mode:
authorFukang Chen <loader@FreeBSD.org>2020-11-13 03:29:37 +0000
committerFukang Chen <loader@FreeBSD.org>2020-11-13 03:29:37 +0000
commitfb508d8168a305b30a6e70826916f65d2f092422 (patch)
tree4283cf77f750d76070620ab4c156aad398def3ee /security/py-ecdsa
parentea792bc0213520af566bbe8e58f654654c09f1f0 (diff)
downloadports-fb508d8168a305b30a6e70826916f65d2f092422.tar.gz
ports-fb508d8168a305b30a6e70826916f65d2f092422.zip
security/py-ecdsa: Update to 0.16.0
- Update to 0.16.0 - Add test target - Pet portlint Changelog: https://github.com/warner/python-ecdsa/releases/tag/python-ecdsa-0.16.0 Reviewed by: koobs Approved by: koobs (ports, mentor, maintainer) Differential Revision: https://reviews.freebsd.org/D27187 MFH: No (API changes, unclear on compatibility)
Notes
Notes: svn path=/head/; revision=555001
Diffstat (limited to 'security/py-ecdsa')
-rw-r--r--security/py-ecdsa/Makefile19
-rw-r--r--security/py-ecdsa/distinfo6
2 files changed, 15 insertions, 10 deletions
diff --git a/security/py-ecdsa/Makefile b/security/py-ecdsa/Makefile
index 5c8302200e79..1d691d0134d5 100644
--- a/security/py-ecdsa/Makefile
+++ b/security/py-ecdsa/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= ecdsa
-PORTVERSION= 0.15
+PORTVERSION= 0.16.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,20 +14,25 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}hypothesis>0:devel/py-hypothesis@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
-OPTIONS_RADIO= FASTER
-OPTIONS_RADIO_FASTER= GMPY GMPY2
-OPTIONS_DEFAULT= GMPY2
+OPTIONS_RADIO= FASTER
+OPTIONS_RADIO_FASTER= GMPY GMPY2
+OPTIONS_DEFAULT= GMPY2
+
+GMPY_DESC= GMPY support
+GMPY2_DESC= GMPY2 support
GMPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gmpy>=0:math/py-gmpy@${PY_FLAVOR}
GMPY2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}gmpy2>=0:math/py-gmpy2@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tox>=0:devel/py-tox@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-
NO_ARCH= yes
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} -m pytest)
+
.include <bsd.port.mk>
diff --git a/security/py-ecdsa/distinfo b/security/py-ecdsa/distinfo
index a10a699949c3..ba990db361aa 100644
--- a/security/py-ecdsa/distinfo
+++ b/security/py-ecdsa/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1595417334
-SHA256 (ecdsa-0.15.tar.gz) = 8f12ac317f8a1318efa75757ef0a651abe12e51fc1af8838fb91079445227277
-SIZE (ecdsa-0.15.tar.gz) = 122119
+TIMESTAMP = 1604999391
+SHA256 (ecdsa-0.16.0.tar.gz) = 494c6a853e9ed2e9be33d160b41d47afc50a6629b993d2b9c5ad7bb226add892
+SIZE (ecdsa-0.16.0.tar.gz) = 125851