aboutsummaryrefslogtreecommitdiff
path: root/security/py-fail2ban
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2014-09-14 19:31:16 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2014-09-14 19:31:16 +0000
commit34fafecef1e4ae4b9693ee9885d495f3b3c37051 (patch)
tree21c4135602557a3268a75cb0cade3178d1cf0df7 /security/py-fail2ban
parenta0b39c7425687db2b3607cb01f3024e7a14caa36 (diff)
downloadports-34fafecef1e4ae4b9693ee9885d495f3b3c37051.tar.gz
ports-34fafecef1e4ae4b9693ee9885d495f3b3c37051.zip
- Patch a script to use the right syslogd socket (/var/run/log)
- Remove .keep_me files because pkg can handle empty directories PR: 193621 Submitted by: theis@gmx.at (maintainer)
Notes
Notes: svn path=/head/; revision=368222
Diffstat (limited to 'security/py-fail2ban')
-rw-r--r--security/py-fail2ban/Makefile6
-rw-r--r--security/py-fail2ban/pkg-plist2
2 files changed, 2 insertions, 6 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index 781aeac1bc49..f3a3f6985b6e 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fail2ban
PORTVERSION= 0.9.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -39,12 +39,12 @@ FILES= ${WRKSRC}/bin/fail2ban-client \
FAIL2BAN_DBDIR= /var/db/${PORTNAME}
post-patch:
-# @${ECHO_CMD} ${FILES} | ${XARGS} ${REINPLACE_CMD} -e 's,/etc/fail2ban,${ETCDIR},g'
@${REINPLACE_CMD} -e 's,/etc/fail2ban,${ETCDIR},g' ${FILES}
@${REINPLACE_CMD} -e 's,paths-debian.conf,paths-freebsd.conf,g' \
${WRKSRC}/config/jail.conf
@${REINPLACE_CMD} -e 's,/var/lib/fail2ban/fail2ban.sqlite3,${FAIL2BAN_DBDIR}/fail2ban.sqlite3,g' \
${WRKSRC}/config/fail2ban.conf
+ @${REINPLACE_CMD} -e 's,"/dev/log","/var/run/log",g' ${WRKSRC}/fail2ban/server/server.py
post-install:
@${MKDIR} ${STAGEDIR}${FAIL2BAN_DBDIR} ${STAGEDIR}/var/run/fail2ban
@@ -54,7 +54,5 @@ post-install:
@${INSTALL_MAN} ${WRKSRC}/man/${file}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
@${INSTALL_MAN} ${WRKSRC}/man/jail.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5/fail2ban-jail.conf.5
- @${TOUCH} ${STAGEDIR}${FAIL2BAN_DBDIR}/.keep_me
- @${TOUCH} ${STAGEDIR}/var/run/fail2ban/.keep_me
.include <bsd.port.mk>
diff --git a/security/py-fail2ban/pkg-plist b/security/py-fail2ban/pkg-plist
index 01afecf59ab2..5f59024ada30 100644
--- a/security/py-fail2ban/pkg-plist
+++ b/security/py-fail2ban/pkg-plist
@@ -204,8 +204,6 @@ man/man1/fail2ban-regex.1.gz
man/man1/fail2ban-server.1.gz
man/man1/fail2ban.1.gz
man/man5/fail2ban-jail.conf.5.gz
-/var/db/fail2ban/.keep_me
-/var/run/fail2ban/.keep_me
@dirrm %%PYTHON_SITELIBDIR%%/fail2ban/tests
@dirrm %%PYTHON_SITELIBDIR%%/fail2ban/server
@dirrm %%PYTHON_SITELIBDIR%%/fail2ban/client