aboutsummaryrefslogtreecommitdiff
path: root/security/py-fail2ban
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-06-16 10:14:21 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-06-16 10:14:21 +0000
commit77ed2dc6244ab9adb3f7f3fe9f942954f65ed87f (patch)
tree5f3329f7202351b704577c19a248c997175ce292 /security/py-fail2ban
parent1bc606ff7e6621244d93ccb18aafe5a918d4585e (diff)
downloadports-77ed2dc6244ab9adb3f7f3fe9f942954f65ed87f.tar.gz
ports-77ed2dc6244ab9adb3f7f3fe9f942954f65ed87f.zip
security/py-fail2ban: Add support for devel/py-pyinotify
* Enable support for devel/py-pyinotify that itself uses devel/libinotify to monitor changes in the filesystem. [1] * Also introduce the new dependency as an additional default option INOTIFY while I'm here because it's not a hard requirement for runtime. [2] PR: 238427 Submitted by: Dmitry Wagin <dmitry.wagin@ya.ru> [1] Approved by: theis@gmx.at (maintainer) [1] [2]
Notes
Notes: svn path=/head/; revision=504294
Diffstat (limited to 'security/py-fail2ban')
-rw-r--r--security/py-fail2ban/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index d5fcd545aad4..3813b63aef16 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -2,7 +2,7 @@
PORTNAME= fail2ban
PORTVERSION= 0.10.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,8 +14,6 @@ LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-OPTIONS_DEFINE= DOCS
-
USES= python:patch shebangfix
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
@@ -32,6 +30,13 @@ PYDISTUTILS_INSTALLARGS+= --install-data=${ETCDIR}
PORTDOCS= README.md DEVELOP
+OPTIONS_DEFINE= DOCS INOTIFY
+OPTIONS_DEFAULT=INOTIFY
+
+INOTIFY_DESC= Support for (lib)inotify to monitor filesystem changes
+
+INOTIFY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyinotify>=0.8.3:devel/py-pyinotify@${PY_FLAVOR}
+
FILES= ${WRKSRC}/bin/fail2ban-client \
${WRKSRC}/fail2ban/client/configreader.py \
${WRKSRC}/fail2ban/client/fail2bancmdline.py \