aboutsummaryrefslogtreecommitdiff
path: root/security/py-fail2ban
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2017-10-15 10:56:01 +0000
committerWen Heping <wen@FreeBSD.org>2017-10-15 10:56:01 +0000
commitcebb6366fa7023888f4cabb3efb3bb0e757171f6 (patch)
treea4c25533df61e326b199928b06bd2066bdc63e67 /security/py-fail2ban
parent833e30e5eba7ffe9ade4df1e423918f7fbc18ad8 (diff)
downloadports-cebb6366fa7023888f4cabb3efb3bb0e757171f6.tar.gz
ports-cebb6366fa7023888f4cabb3efb3bb0e757171f6.zip
- Update to 0.10.1
PR: 223022 Submitted by: theis@gmx.at(maintainer)
Notes
Notes: svn path=/head/; revision=452134
Diffstat (limited to 'security/py-fail2ban')
-rw-r--r--security/py-fail2ban/Makefile2
-rw-r--r--security/py-fail2ban/distinfo6
-rw-r--r--security/py-fail2ban/files/patch-fail2ban_server_ipdns.py19
3 files changed, 4 insertions, 23 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index bcccfb174a6f..7a909e612179 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= fail2ban
-PORTVERSION= 0.10.0
+PORTVERSION= 0.10.1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-fail2ban/distinfo b/security/py-fail2ban/distinfo
index 88c6445ac759..e4ee9d70a386 100644
--- a/security/py-fail2ban/distinfo
+++ b/security/py-fail2ban/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1502542383
-SHA256 (fail2ban-fail2ban-0.10.0_GH0.tar.gz) = 3517b68bff71924f179609eb51dd2fe66d78653646528cdf8edf2370ff047c80
-SIZE (fail2ban-fail2ban-0.10.0_GH0.tar.gz) = 459813
+TIMESTAMP = 1508093600
+SHA256 (fail2ban-fail2ban-0.10.1_GH0.tar.gz) = 19bac652e50f35b3b58ea010c2b89b91b945365d37dbf17467e0dc345c058465
+SIZE (fail2ban-fail2ban-0.10.1_GH0.tar.gz) = 465156
diff --git a/security/py-fail2ban/files/patch-fail2ban_server_ipdns.py b/security/py-fail2ban/files/patch-fail2ban_server_ipdns.py
deleted file mode 100644
index 25386c2142b5..000000000000
--- a/security/py-fail2ban/files/patch-fail2ban_server_ipdns.py
+++ /dev/null
@@ -1,19 +0,0 @@
---- fail2ban/server/ipdns.py.orig 2017-08-09 14:53:05 UTC
-+++ fail2ban/server/ipdns.py
-@@ -69,10 +69,14 @@ class DNSUtils:
- for fam, ipfam in ((socket.AF_INET, IPAddr.FAM_IPv4), (socket.AF_INET6, IPAddr.FAM_IPv6)):
- try:
- for result in socket.getaddrinfo(dns, None, fam, 0, socket.IPPROTO_TCP):
-- ip = IPAddr(result[4][0], ipfam)
-+ # if getaddrinfo returns something unexpected:
-+ if len(result) < 4 or not len(result[4]): continue
-+ # be sure we have an ip-string
-+ # some return an integer there
-+ ip = IPAddr(str(result[4][0]), ipfam)
- if ip.isValid:
- ips.append(ip)
-- except socket.error as e:
-+ except Exception as e:
- saveerr = e
- if not ips and saveerr:
- logSys.warning("Unable to find a corresponding IP address for %s: %s", dns, saveerr)