aboutsummaryrefslogtreecommitdiff
path: root/security/py-fail2ban
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-16 17:00:05 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2015-03-16 17:00:05 +0000
commitdc7f9718a85ed919b0ab8ba8afec66ee3f139a49 (patch)
tree9d0d09c46b14443295907ffc782654db3d93bb85 /security/py-fail2ban
parentc1e595f8b683c802c6ee64462f6b1d4ba62c1d1d (diff)
downloadports-dc7f9718a85ed919b0ab8ba8afec66ee3f139a49.tar.gz
ports-dc7f9718a85ed919b0ab8ba8afec66ee3f139a49.zip
- Fix build with python3*
- Do not silence installation message PR: 196336 Submitted by: Kevin Zheng <kevinz5000@gmail.com> Approved by: <theis@gmx.at> (maintainer)
Notes
Notes: svn path=/head/; revision=381426
Diffstat (limited to 'security/py-fail2ban')
-rw-r--r--security/py-fail2ban/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/security/py-fail2ban/Makefile b/security/py-fail2ban/Makefile
index a7c3afd35307..8bd564cd62f9 100644
--- a/security/py-fail2ban/Makefile
+++ b/security/py-fail2ban/Makefile
@@ -18,8 +18,8 @@ GH_PROJECT= ${PORTNAME}
GH_COMMIT= 2ab2bd8
GH_TAGNAME= ${PORTVERSION}
-USES= python:2
-USE_PYTHON= distutils
+USES= python
+USE_PYTHON= distutils py3kplist
USE_RC_SUBR= fail2ban
SUB_LIST+= PYTHON_CMD=${PYTHON_CMD}
@@ -50,8 +50,8 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/ && ${INSTALL_DATA} ${PORTDOCS} ${STAGEDIR}${DOCSDIR})
.for file in fail2ban-client fail2ban-regex fail2ban-server fail2ban
- @${INSTALL_MAN} ${WRKSRC}/man/${file}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/man/${file}.1 ${STAGEDIR}${MANPREFIX}/man/man1
.endfor
- @${INSTALL_MAN} ${WRKSRC}/man/jail.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5/fail2ban-jail.conf.5
+ ${INSTALL_MAN} ${WRKSRC}/man/jail.conf.5 ${STAGEDIR}${MANPREFIX}/man/man5/fail2ban-jail.conf.5
.include <bsd.port.mk>