aboutsummaryrefslogtreecommitdiff
path: root/security/py-first-server
diff options
context:
space:
mode:
authorDan Langille <dvl@FreeBSD.org>2017-09-11 15:20:06 +0000
committerDan Langille <dvl@FreeBSD.org>2017-09-11 15:20:06 +0000
commit28286a4a8c11c77dc929ee62b41f8a4c68befbcc (patch)
treed4db022e39b170c9867e42b64bca76ca77a9fd3d /security/py-first-server
parenta593cb279c4dc0ea2cb3e2db51cc319820608146 (diff)
downloadports-28286a4a8c11c77dc929ee62b41f8a4c68befbcc.tar.gz
ports-28286a4a8c11c77dc929ee62b41f8a4c68befbcc.zip
Upgrade to 0.0.2
Notes
Notes: svn path=/head/; revision=449655
Diffstat (limited to 'security/py-first-server')
-rw-r--r--security/py-first-server/Makefile7
-rw-r--r--security/py-first-server/distinfo6
-rw-r--r--security/py-first-server/pkg-message7
-rw-r--r--security/py-first-server/pkg-plist38
4 files changed, 39 insertions, 19 deletions
diff --git a/security/py-first-server/Makefile b/security/py-first-server/Makefile
index 671b2df7c179..f393296c1fa1 100644
--- a/security/py-first-server/Makefile
+++ b/security/py-first-server/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= first-server
-PORTVERSION= 0.0.1
+PORTVERSION= 0.0.2
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTVERSIONPREFIX= v
@@ -13,13 +13,12 @@ COMMENT= Function Identification and Recovery Signature Tool
LICENSE= GPLv2
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mysqlclient>=1.3.8:databases/py-mysqlclient
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}mongoengine>=0.10.0:devel/py-mongoengine
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}django>=1.10.2:www/py-django
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}django>=1.11.4:www/py-django
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}werkzeug>=0.11.11:www/py-werkzeug
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}httplib2>=0.9.2:www/py-httplib2
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}oauth2client>=3.0.0:security/py-oauth2client
RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}google-api-python-client>=1.5.3:www/py-google-api-python-client
-RUN_DEPENDS+= distorm>=0:devel/distorm
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}capstone>=3.0.4:devel/py-capstone
USE_GITHUB= yes
GH_ACCOUNT= vrtadmin
diff --git a/security/py-first-server/distinfo b/security/py-first-server/distinfo
index 5f4617cf8186..27631c86d6c4 100644
--- a/security/py-first-server/distinfo
+++ b/security/py-first-server/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501161109
-SHA256 (vrtadmin-FIRST-server-v0.0.1_GH0.tar.gz) = 6d4ea5dc46b8557a31d644e1c1fe34d0575111aa39db0507b64a191b4e984d6e
-SIZE (vrtadmin-FIRST-server-v0.0.1_GH0.tar.gz) = 2248663
+TIMESTAMP = 1505142587
+SHA256 (vrtadmin-FIRST-server-v0.0.2_GH0.tar.gz) = 28142ea5326cfecde6663e21b84e71d69e16c317dd52c83b116c5ac999f70ff5
+SIZE (vrtadmin-FIRST-server-v0.0.2_GH0.tar.gz) = 2254487
diff --git a/security/py-first-server/pkg-message b/security/py-first-server/pkg-message
new file mode 100644
index 000000000000..b25e9a5a55d4
--- /dev/null
+++ b/security/py-first-server/pkg-message
@@ -0,0 +1,7 @@
+
+As of version 0.0.2, FIRST no longer requires these packages:
+
+* distorm3
+* mongoengine
+
+You may want to remove them.
diff --git a/security/py-first-server/pkg-plist b/security/py-first-server/pkg-plist
index 5b298e59533c..5f6cd1ac4a5b 100644
--- a/security/py-first-server/pkg-plist
+++ b/security/py-first-server/pkg-plist
@@ -1,18 +1,29 @@
+%%WWWDIR%%/engines/__init__.py
+%%WWWDIR%%/engines/admin.py
+%%WWWDIR%%/engines/apps.py
+%%WWWDIR%%/engines/migrations/__init__.py
+%%WWWDIR%%/engines/models.py
+%%WWWDIR%%/engines/tests.py
+%%WWWDIR%%/engines/views.py
+%%WWWDIR%%/example_config.json
%%WWWDIR%%/first/__init__.py
-%%WWWDIR%%/first/auth.py
-%%WWWDIR%%/first/dbs/__init__.py
-%%WWWDIR%%/first/dbs/builtin_db.py
-%%WWWDIR%%/first/engines/__init__.py
-%%WWWDIR%%/first/engines/basic_masking.py
-%%WWWDIR%%/first/engines/exact_match.py
-%%WWWDIR%%/first/engines/mnemonic_hash.py
-%%WWWDIR%%/first/engines/results.py
-%%WWWDIR%%/first/engines/skeleton.py_
-%%WWWDIR%%/first/error.py
-%%WWWDIR%%/first/models.py
%%WWWDIR%%/first/settings.py
%%WWWDIR%%/first/urls.py
%%WWWDIR%%/first/wsgi.py
+%%WWWDIR%%/first_core/__init__.py
+%%WWWDIR%%/first_core/auth.py
+%%WWWDIR%%/first_core/dbs/__init__.py
+%%WWWDIR%%/first_core/dbs/builtin_db.py
+%%WWWDIR%%/first_core/disassembly/__init__.py
+%%WWWDIR%%/first_core/engines/__init__.py
+%%WWWDIR%%/first_core/engines/basic_masking.py
+%%WWWDIR%%/first_core/engines/exact_match.py
+%%WWWDIR%%/first_core/engines/mnemonic_hash.py
+%%WWWDIR%%/first_core/engines/results.py
+%%WWWDIR%%/first_core/engines/skeleton.py_
+%%WWWDIR%%/first_core/error.py
+%%WWWDIR%%/first_core/models.py
+%%WWWDIR%%/first_core/util.py
%%WWWDIR%%/manage.py
%%WWWDIR%%/rest/__init__.py
%%WWWDIR%%/rest/admin.py
@@ -23,12 +34,15 @@
%%WWWDIR%%/rest/tests.py
%%WWWDIR%%/rest/urls.py
%%WWWDIR%%/rest/views.py
+%%WWWDIR%%/utilities/__init__.py
%%WWWDIR%%/utilities/engine_shell.py
-%%WWWDIR%%/utilities/populate_engine.py
+%%WWWDIR%%/utilities/mongo_to_django_orm.py
%%WWWDIR%%/utilities/test_engine.py
+%%WWWDIR%%/utilities/user_shell.py
%%WWWDIR%%/www/__init__.py
%%WWWDIR%%/www/admin.py
%%WWWDIR%%/www/apps.py
+%%WWWDIR%%/www/migrations/0001_initial.py
%%WWWDIR%%/www/migrations/__init__.py
%%WWWDIR%%/www/models.py
%%WWWDIR%%/www/static/www/Thumbs.db