aboutsummaryrefslogtreecommitdiff
path: root/security/py-flask-httpauth
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2015-04-08 10:58:05 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2015-04-08 10:58:05 +0000
commitf848c882de14f628ede81fc7c5d122f19111e3c7 (patch)
treeae5a10e3b760bc48bc0b2d15fcfb774b70424e14 /security/py-flask-httpauth
parent73df72fff98af0c9289dcf8daee9ef22fd355204 (diff)
downloadports-f848c882de14f628ede81fc7c5d122f19111e3c7.tar.gz
ports-f848c882de14f628ede81fc7c5d122f19111e3c7.zip
Basic and Digest HTTP authentication for Flask routes.
Notes
Notes: svn path=/head/; revision=383561
Diffstat (limited to 'security/py-flask-httpauth')
-rw-r--r--security/py-flask-httpauth/Makefile17
-rw-r--r--security/py-flask-httpauth/distinfo2
-rw-r--r--security/py-flask-httpauth/pkg-descr3
3 files changed, 22 insertions, 0 deletions
diff --git a/security/py-flask-httpauth/Makefile b/security/py-flask-httpauth/Makefile
new file mode 100644
index 000000000000..8e5d35e81975
--- /dev/null
+++ b/security/py-flask-httpauth/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= Flask-HTTPAuth
+PORTVERSION= 2.4.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Basic and Digest HTTP authentication for Flask routes
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>0:${PORTSDIR}/www/py-flask
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-flask-httpauth/distinfo b/security/py-flask-httpauth/distinfo
new file mode 100644
index 000000000000..e27aaf171efb
--- /dev/null
+++ b/security/py-flask-httpauth/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Flask-HTTPAuth-2.4.0.tar.gz) = bdab2c61fb68f620710513d9ef2440745c011873efe7395c9e4e38bc53d9350f
+SIZE (Flask-HTTPAuth-2.4.0.tar.gz) = 2433
diff --git a/security/py-flask-httpauth/pkg-descr b/security/py-flask-httpauth/pkg-descr
new file mode 100644
index 000000000000..7adca4631c82
--- /dev/null
+++ b/security/py-flask-httpauth/pkg-descr
@@ -0,0 +1,3 @@
+Basic and Digest HTTP authentication for Flask routes.
+
+WWW: http://github.com/miguelgrinberg/flask-httpauth/