aboutsummaryrefslogtreecommitdiff
path: root/security/py-google-auth
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-12 16:07:56 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-12 16:07:56 +0000
commitadc69dfc5360d8b69404f92a8449cc4db9e647e8 (patch)
tree72101fa38480b62f2883ebde089e73634b04179b /security/py-google-auth
parent1a28f71ff2247788b000959724118366a2ea9185 (diff)
downloadports-adc69dfc5360d8b69404f92a8449cc4db9e647e8.tar.gz
ports-adc69dfc5360d8b69404f92a8449cc4db9e647e8.zip
Update RUN_DEPENDS for py-cachetools 4.0.0 update
- Bump PORTREVISION for dependency change
Notes
Notes: svn path=/head/; revision=522809
Diffstat (limited to 'security/py-google-auth')
-rw-r--r--security/py-google-auth/Makefile14
1 files changed, 11 insertions, 3 deletions
diff --git a/security/py-google-auth/Makefile b/security/py-google-auth/Makefile
index b2c4c5fe4e50..8779e317f049 100644
--- a/security/py-google-auth/Makefile
+++ b/security/py-google-auth/Makefile
@@ -3,6 +3,7 @@
PORTNAME= google-auth
PORTVERSION= 1.10.0
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,8 +14,7 @@ COMMENT= Google Authentication Library
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cachetools>=2.0.0<5.0:devel/py-cachetools@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0.2.1:devel/py-pyasn1-modules@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1-modules>=0.2.1:devel/py-pyasn1-modules@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}rsa>=3.1.4<4.1:security/py-rsa@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
@@ -23,4 +23,12 @@ USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3500
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cachetools3>=2.0.0<5.0:devel/py-cachetools3@${PY_FLAVOR}
+.else
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}cachetools>=2.0.0<5.0:devel/py-cachetools@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>