aboutsummaryrefslogtreecommitdiff
path: root/security/py-gpgme
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-02-02 23:30:34 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-02-02 23:30:34 +0000
commit0ed45d94036a6efcb238f6e09e14f2927c57e622 (patch)
tree5b901af42e538050dc6ebb3d21304ed142075485 /security/py-gpgme
parent5faa586c7092862f64e72d0d3ec078cef502453c (diff)
downloadports-0ed45d94036a6efcb238f6e09e14f2927c57e622.tar.gz
ports-0ed45d94036a6efcb238f6e09e14f2927c57e622.zip
Add a TEST option to toggle in-build testing as it was causing trouble when
the test build directory path length was longer than the maximum socket path length. A workaround to this problem is noted in the Makefile. [1] Prevent the GNUPG1 option and the TEST option from being enabled simultaneously since the tests mainly revolve around the programs supplied with GnuPG 2.x. Disable in-build tests for slave ports for now. Move the flavor logic for the python slave port into the slave port Makefile as it was not being evaluated correctly when in the master port Makefile. Reported by: tijl (via private mail) [1]
Notes
Notes: svn path=/head/; revision=460759
Diffstat (limited to 'security/py-gpgme')
-rw-r--r--security/py-gpgme/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/py-gpgme/Makefile b/security/py-gpgme/Makefile
index 3a9ec15b130e..da04d23b06f3 100644
--- a/security/py-gpgme/Makefile
+++ b/security/py-gpgme/Makefile
@@ -12,6 +12,12 @@ SLAVEPORT= python
BINDING_NAME= python
PLIST= ${.CURDIR}/pkg-plist
+.if ${FLAVOR:Upy27:Mpy2*}
+CONFIGURE_ARGS+=--enable-languages="python2"
+.else
+CONFIGURE_ARGS+=--enable-languages="python3"
+.endif
+
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages/gpg/_gpgme.so