aboutsummaryrefslogtreecommitdiff
path: root/security/py-gpgme
diff options
context:
space:
mode:
authorJason E. Hale <jhale@FreeBSD.org>2018-02-06 15:18:23 +0000
committerJason E. Hale <jhale@FreeBSD.org>2018-02-06 15:18:23 +0000
commite798b0e1b90937b814ae64b6a9bc02d3dc5e4a95 (patch)
treebbbf2fabafddb93c248afddae8ba2fb417228701 /security/py-gpgme
parente40f2df91b35d4d9e4e6f7682d95a18b04612ce2 (diff)
downloadports-e798b0e1b90937b814ae64b6a9bc02d3dc5e4a95.tar.gz
ports-e798b0e1b90937b814ae64b6a9bc02d3dc5e4a95.zip
security/gpgme:
- Add some magic to support the regression tests in the case where the test build directory path length exceeds the maximum socket path length. - Fix shebang in the pinentry test script. At long last, the real reason some of the tests were failing has been discovered! - Remove files/patch-tests_gpg_Makefile.in now that the pinentry script is fixed. - Move USES upward. security/gpgme-cpp: - Remove workaround for Bug 193528 (fixed in GCC 6+) security/gpgme-qt5: - Add full test support. - QT5 testlib only needed for tests at build time. - Add DOXYGEN option to install the API documentation. Prevent the automatic building of the docs if doxygen happens to be installed. - Bump PORTREVISION due to added options / dependency change security/py-gpgme: - Add full test support. - Revert flavor logic move from r460759. The logic being below <bsd.port.options.mk> was the reason it wasn't previously working. - Bump PORTREVISION due to added option
Notes
Notes: svn path=/head/; revision=461063
Diffstat (limited to 'security/py-gpgme')
-rw-r--r--security/py-gpgme/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/security/py-gpgme/Makefile b/security/py-gpgme/Makefile
index da04d23b06f3..17cbc7ac6949 100644
--- a/security/py-gpgme/Makefile
+++ b/security/py-gpgme/Makefile
@@ -1,6 +1,6 @@
# $FreeBSD$
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,12 +12,6 @@ SLAVEPORT= python
BINDING_NAME= python
PLIST= ${.CURDIR}/pkg-plist
-.if ${FLAVOR:Upy27:Mpy2*}
-CONFIGURE_ARGS+=--enable-languages="python2"
-.else
-CONFIGURE_ARGS+=--enable-languages="python3"
-.endif
-
post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/${PYTHON_VERSION}/site-packages/gpg/_gpgme.so