aboutsummaryrefslogtreecommitdiff
path: root/security/py-gpsoauth
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2017-04-22 11:45:12 +0000
committerThomas Zander <riggs@FreeBSD.org>2017-04-22 11:45:12 +0000
commit5945186baa7cf92865d292fc0e291469dc355c51 (patch)
tree1fad520943d50890886fdf47bffa722dcfe32557 /security/py-gpsoauth
parentf5148794f05138446434ee041411fe4d725dfec6 (diff)
downloadports-5945186baa7cf92865d292fc0e291469dc355c51.tar.gz
ports-5945186baa7cf92865d292fc0e291469dc355c51.zip
Update to upstream version 0.4.1; use security/py-pycryptodome
Notes
Notes: svn path=/head/; revision=439164
Diffstat (limited to 'security/py-gpsoauth')
-rw-r--r--security/py-gpsoauth/Makefile6
-rw-r--r--security/py-gpsoauth/distinfo6
-rw-r--r--security/py-gpsoauth/files/patch-gpsoauth_google.py13
3 files changed, 19 insertions, 6 deletions
diff --git a/security/py-gpsoauth/Makefile b/security/py-gpsoauth/Makefile
index e8de2e935aee..a4353326573a 100644
--- a/security/py-gpsoauth/Makefile
+++ b/security/py-gpsoauth/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gpsoauth
-PORTVERSION= 0.1.0
+PORTVERSION= 0.4.1
CATEGORIES= security python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,9 +12,9 @@ COMMENT= Python client library for Google Play Services OAuth
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.6.1:security/py-pycrypto \
- ${PYTHON_PKGNAMEPREFIX}requests>=2.7.0:www/py-requests \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.9.1:www/py-requests \
${PYTHON_PKGNAMEPREFIX}ndg_httpsclient>0:net/py-ndg_httpsclient \
+ ${PYTHON_PKGNAMEPREFIX}pycryptodome>=3.4:security/py-pycryptodome \
${PYTHON_PKGNAMEPREFIX}openssl>0:security/py-openssl \
${PYTHON_PKGNAMEPREFIX}pyasn1>0:devel/py-pyasn1
diff --git a/security/py-gpsoauth/distinfo b/security/py-gpsoauth/distinfo
index 157277fa5a63..a9ff6ab378ed 100644
--- a/security/py-gpsoauth/distinfo
+++ b/security/py-gpsoauth/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1464783417
-SHA256 (simon-weber-gpsoauth-0.1.0_GH0.tar.gz) = 3dd9470f6b2985f71e3bff1bd7640d6e599bfc5a773fc0c493a266dd2b83cb65
-SIZE (simon-weber-gpsoauth-0.1.0_GH0.tar.gz) = 5082
+TIMESTAMP = 1492856940
+SHA256 (simon-weber-gpsoauth-0.4.1_GH0.tar.gz) = 062b5660b1cf723cca1381f311153b94ce36088ce19014665fdbbb6374377f13
+SIZE (simon-weber-gpsoauth-0.4.1_GH0.tar.gz) = 4962
diff --git a/security/py-gpsoauth/files/patch-gpsoauth_google.py b/security/py-gpsoauth/files/patch-gpsoauth_google.py
new file mode 100644
index 000000000000..231c5dcae6e8
--- /dev/null
+++ b/security/py-gpsoauth/files/patch-gpsoauth_google.py
@@ -0,0 +1,13 @@
+--- gpsoauth/google.py.orig 2017-02-18 18:11:10 UTC
++++ gpsoauth/google.py
+@@ -1,8 +1,8 @@
+ import base64
+ import hashlib
+
+-from Cryptodome.PublicKey import RSA
+-from Cryptodome.Cipher import PKCS1_OAEP
++from Crypto.PublicKey import RSA
++from Crypto.Cipher import PKCS1_OAEP
+
+ from .util import bytes_to_long, long_to_bytes
+