aboutsummaryrefslogtreecommitdiff
path: root/security/py-gssapi
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2018-06-20 01:38:58 +0000
committerMartin Wilke <miwi@FreeBSD.org>2018-06-20 01:38:58 +0000
commitb78a2a594158521465a958ca7315a0baedb524d4 (patch)
treedf0b521ab46cad5ad223580e2e80e01ff7b866c5 /security/py-gssapi
parente51447a36c9057fcce411439360d258f3ca70986 (diff)
downloadports-b78a2a594158521465a958ca7315a0baedb524d4.tar.gz
ports-b78a2a594158521465a958ca7315a0baedb524d4.zip
Python-GSSAPI provides both low-level and high level wrappers around
the GSSAPI C libraries. While it focuses on the Kerberos mechanism, it should also be usable with other GSSAPI mechanisms. WWW: https://github.com/pythongssapi/python-gssapi PR: 228523 Submitted by: john@saltant.com
Notes
Notes: svn path=/head/; revision=472837
Diffstat (limited to 'security/py-gssapi')
-rw-r--r--security/py-gssapi/Makefile32
-rw-r--r--security/py-gssapi/distinfo3
-rw-r--r--security/py-gssapi/pkg-descr5
3 files changed, 40 insertions, 0 deletions
diff --git a/security/py-gssapi/Makefile b/security/py-gssapi/Makefile
new file mode 100644
index 000000000000..ed391f819b0e
--- /dev/null
+++ b/security/py-gssapi/Makefile
@@ -0,0 +1,32 @@
+# $FreeBSD$
+
+PORTNAME= gssapi
+DISTVERSION= 1.5.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= john@saltant.com
+COMMENT= High-level and low-level Python bindings to GSSAPI C libraries
+
+LICENSE= ISCL
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}decorator>0:devel/py-decorator@${PY_FLAVOR} \
+ ${PY_ENUM34}
+
+OPTIONS_RADIO= GSSAPI
+OPTIONS_RADIO_GSSAPI= GSSAPI_BASE GSSAPI_HEIMDAL GSSAPI_MIT
+OPTIONS_DEFAULT= GSSAPI_BASE
+
+GSSAPI_BASE_USES= gssapi
+GSSAPI_HEIMDAL_USES= gssapi:heimdal
+GSSAPI_MIT_USES= gssapi:mit
+
+USES= python
+USE_PYTHON= distutils autoplist
+
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%KRB5CONFIG%%|${KRB5CONFIG}|' ${WRKSRC}/setup.py
+
+.include <bsd.port.mk>
diff --git a/security/py-gssapi/distinfo b/security/py-gssapi/distinfo
new file mode 100644
index 000000000000..774a52d729de
--- /dev/null
+++ b/security/py-gssapi/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1527359672
+SHA256 (gssapi-1.5.0.tar.gz) = be715cb74ac56db2dd888b016097aaa29ab7d7d34c1f8c706ff63f76b3553f71
+SIZE (gssapi-1.5.0.tar.gz) = 958382
diff --git a/security/py-gssapi/pkg-descr b/security/py-gssapi/pkg-descr
new file mode 100644
index 000000000000..560da8bbe888
--- /dev/null
+++ b/security/py-gssapi/pkg-descr
@@ -0,0 +1,5 @@
+Python-GSSAPI provides both low-level and high level wrappers around
+the GSSAPI C libraries. While it focuses on the Kerberos mechanism, it
+should also be usable with other GSSAPI mechanisms.
+
+WWW: https://github.com/pythongssapi/python-gssapi