aboutsummaryrefslogtreecommitdiff
path: root/security/py-htpasswd
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-02-02 00:04:24 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-02-02 00:04:24 +0000
commit95b3ec7ec4fe5ce4ccf556ea810f8daeed493b5f (patch)
tree6094f39076f2d4dc19febb4bfae49a1d5cf24dc2 /security/py-htpasswd
parent19a1734fbb5f32640cf43e115f23119582f24146 (diff)
downloadports-95b3ec7ec4fe5ce4ccf556ea810f8daeed493b5f.tar.gz
ports-95b3ec7ec4fe5ce4ccf556ea810f8daeed493b5f.zip
- fix sed regular expression
- don't clobber do-patch while here PR: ports/164693 Submitted by: maintainer, graudeejs at gmail.com Approved by: crees, rene (mentors, implicit)
Notes
Notes: svn path=/head/; revision=290265
Diffstat (limited to 'security/py-htpasswd')
-rw-r--r--security/py-htpasswd/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/security/py-htpasswd/Makefile b/security/py-htpasswd/Makefile
index 8aa9114748b4..3abc2f91d77a 100644
--- a/security/py-htpasswd/Makefile
+++ b/security/py-htpasswd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= htpasswd
PORTVERSION= 2008.03.05
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security python
MASTER_SITES= http://files.bsdroot.lv/my/FreeBSD/distfiles/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -23,8 +23,9 @@ PLIST_FILES= bin/${PORTNAME}.py
NO_BUILD= YES
NO_WRKSUBDIR= YES
-do-patch:
- ${SED} -I.orig -e 's#^/usr/bin/python#/usr/bin/env python#' ${WRKDIR}/${PORTNAME}.py
+post-patch:
+ ${SED} -I.orig -e 's|^#!/usr/bin/python|#!/usr/bin/env python|' ${WRKDIR}/${PORTNAME}.py
+
do-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME}.py ${PREFIX}/bin/