aboutsummaryrefslogtreecommitdiff
path: root/security/py-netmiko
diff options
context:
space:
mode:
authorKai Knoblich <kai@FreeBSD.org>2019-02-28 14:32:17 +0000
committerKai Knoblich <kai@FreeBSD.org>2019-02-28 14:32:17 +0000
commitccf486033c467677a2c2c24a6f56277f1b866a0a (patch)
tree020b15979acc119a10aaac4dd312acb936043f90 /security/py-netmiko
parentfbdab0cec1e935b13eb71b6450e92aa0242f6de2 (diff)
downloadports-ccf486033c467677a2c2c24a6f56277f1b866a0a.tar.gz
ports-ccf486033c467677a2c2c24a6f56277f1b866a0a.zip
security/py-netmiko: Update to 2.3.0
* Pacify portlint [1] * Switch to GitHub to enable test target [2] Notable changes since 2.1.1: * Add support for new platforms: - Apresia Systems AEOS - Citrix Netscaler - Dell EMC Isilon, Dell OS10 and DNOS6 - IP Infusion OcNOS - RAD ETX * Add fast_cli mode to improve performance * Add support for a session_log * Add Paramiko pkey, auth_timeout and passphrase support Changelog: https://github.com/ktbyers/netmiko/releases/tag/v2.3.0 PR: 236036 Submitted by: John W. O'Brien <john@saltant.com> [1] Reviewed by: koobs [2] Approved by: miwi (mentor) Differential Revision: https://reviews.freebsd.org/D19361
Notes
Notes: svn path=/head/; revision=494152
Diffstat (limited to 'security/py-netmiko')
-rw-r--r--security/py-netmiko/Makefile17
-rw-r--r--security/py-netmiko/distinfo6
2 files changed, 16 insertions, 7 deletions
diff --git a/security/py-netmiko/Makefile b/security/py-netmiko/Makefile
index dd13e91194b1..dfcfcea7443a 100644
--- a/security/py-netmiko/Makefile
+++ b/security/py-netmiko/Makefile
@@ -1,9 +1,9 @@
# $FreeBSD$
PORTNAME= netmiko
-DISTVERSION= 2.1.1
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.3.0
CATEGORIES= security python
-MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= kai@FreeBSD.org
@@ -12,14 +12,23 @@ COMMENT= Multi-vendor library to simplify SSH connections to network devices
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=2.0.0:security/py-paramiko@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}paramiko>=2.4.1:security/py-paramiko@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}serial>0:comms/py-serial@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}scp>=0.10.0:security/py-scp@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}textfsm>0:textproc/py-textfsm@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR} \
+ ${PY_IPADDRESS} \
+ ${PY_ENUM34}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
USES= python
USE_PYTHON= distutils autoplist
+USE_GITHUB= yes
+GH_ACCOUNT= ktbyers
+
NO_ARCH= yes
+do-test:
+ cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -s tests/test_import_netmiko.py
+
.include <bsd.port.mk>
diff --git a/security/py-netmiko/distinfo b/security/py-netmiko/distinfo
index 18e72f49ded2..f367e4be1937 100644
--- a/security/py-netmiko/distinfo
+++ b/security/py-netmiko/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1522350835
-SHA256 (netmiko-2.1.1.tar.gz) = f9051df1895e27b7f245e8a350d9116ae476bec811776a9fe63e827b8dedcf9b
-SIZE (netmiko-2.1.1.tar.gz) = 71410
+TIMESTAMP = 1551174300
+SHA256 (ktbyers-netmiko-v2.3.0_GH0.tar.gz) = f9e062044b6ee4ed980560c0356961c6c0fc0e486a9c3b1d806f68cd680e3893
+SIZE (ktbyers-netmiko-v2.3.0_GH0.tar.gz) = 971985