aboutsummaryrefslogtreecommitdiff
path: root/security/py-oauthlib
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2012-06-15 11:22:44 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2012-06-15 11:22:44 +0000
commitfc9240610ad3dace0fcb6ee19facdae4dd17e5cc (patch)
treefd28fa8d990a266db9a05b26634692ee61175417 /security/py-oauthlib
parent04a0d5207809afa5b7148b2ca3680aee8e77b384 (diff)
downloadports-fc9240610ad3dace0fcb6ee19facdae4dd17e5cc.tar.gz
ports-fc9240610ad3dace0fcb6ee19facdae4dd17e5cc.zip
- remove unneded LICENSE_FILE knob
- add dependency on py-rsa to RUN_DEPENDS too - mark this port python3 ready - remove trailing slash from pkg-plist entry - bump PORTREVISION because of dependency change PR: 169068 (follow-up patch) Submitted by: rm (myself) Approved by: koobs k <koobs.freebsd at gmail dot com> (maintainer)
Notes
Notes: svn path=/head/; revision=299343
Diffstat (limited to 'security/py-oauthlib')
-rw-r--r--security/py-oauthlib/Makefile10
-rw-r--r--security/py-oauthlib/pkg-plist2
2 files changed, 7 insertions, 5 deletions
diff --git a/security/py-oauthlib/Makefile b/security/py-oauthlib/Makefile
index bab5a0d7c0a0..fd805c389015 100644
--- a/security/py-oauthlib/Makefile
+++ b/security/py-oauthlib/Makefile
@@ -1,12 +1,13 @@
# New ports collection makefile for: py-oauthlib
-# Date created: 2012-05-23
-# Whom: koobs <koobs.freebsd@gmail.com>
+# Date created: 2012-05-23
+# Whom: koobs <koobs.freebsd@gmail.com>
#
# $FreeBSD$
#
PORTNAME= oauthlib
PORTVERSION= 0.1.3
+PORTREVISION= 1
CATEGORIES= security net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -15,10 +16,11 @@ MAINTAINER= koobs.freebsd@gmail.com
COMMENT= An RFC-compliant Python implementation of OAuth
LICENSE= BSD
-LICENSE_FILE= ${WRKSRC}/LICENSE
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}rsa>=0:${PORTSDIR}/security/py-rsa
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}rsa>0:${PORTSDIR}/security/py-rsa
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+# Python3 ready
USE_PYTHON= yes
USE_PYDISTUTILS=easy_install
diff --git a/security/py-oauthlib/pkg-plist b/security/py-oauthlib/pkg-plist
index 15537c9e36e2..e44aa1884add 100644
--- a/security/py-oauthlib/pkg-plist
+++ b/security/py-oauthlib/pkg-plist
@@ -44,4 +44,4 @@
@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauthlib/oauth1
@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/oauthlib
@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/EGG-INFO
-@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%/
+@dirrm %%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%