aboutsummaryrefslogtreecommitdiff
path: root/security/py-openssl
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-11 14:54:44 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-11 14:54:44 +0000
commit3d883b3a8872dbdfb4b42629815f8c07cb3e09b2 (patch)
treeda59431155fd36e92a631abf82d9ec95d23730b4 /security/py-openssl
parentb140243697f05bcb9ecd8441b26df95f67fdf544 (diff)
downloadports-3d883b3a8872dbdfb4b42629815f8c07cb3e09b2.tar.gz
ports-3d883b3a8872dbdfb4b42629815f8c07cb3e09b2.zip
add py-openssl 0.4.1
Python interface to the OpenSSL library
Notes
Notes: svn path=/head/; revision=54560
Diffstat (limited to 'security/py-openssl')
-rw-r--r--security/py-openssl/Makefile30
-rw-r--r--security/py-openssl/distinfo1
-rw-r--r--security/py-openssl/pkg-comment1
-rw-r--r--security/py-openssl/pkg-descr3
-rw-r--r--security/py-openssl/pkg-plist8
5 files changed, 43 insertions, 0 deletions
diff --git a/security/py-openssl/Makefile b/security/py-openssl/Makefile
new file mode 100644
index 000000000000..703488d58b00
--- /dev/null
+++ b/security/py-openssl/Makefile
@@ -0,0 +1,30 @@
+# ex:ts=8
+# Ports collection makefile for: py-openssl
+# Date created: Feb 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= openssl
+PORTVERSION= 0.4.1
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= pyopenssl
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= pyOpenSSL-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+USE_OPENSSL= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+
+.include <bsd.port.mk>
diff --git a/security/py-openssl/distinfo b/security/py-openssl/distinfo
new file mode 100644
index 000000000000..0ea66ce27a51
--- /dev/null
+++ b/security/py-openssl/distinfo
@@ -0,0 +1 @@
+MD5 (pyOpenSSL-0.4.1.tar.gz) = 21d4337fb58bf45e54cd8574c64cb323
diff --git a/security/py-openssl/pkg-comment b/security/py-openssl/pkg-comment
new file mode 100644
index 000000000000..b400c8faf0f2
--- /dev/null
+++ b/security/py-openssl/pkg-comment
@@ -0,0 +1 @@
+Python interface to the OpenSSL library
diff --git a/security/py-openssl/pkg-descr b/security/py-openssl/pkg-descr
new file mode 100644
index 000000000000..74ed8babc846
--- /dev/null
+++ b/security/py-openssl/pkg-descr
@@ -0,0 +1,3 @@
+pyOpenSSL - A Python wrapper around the OpenSSL library
+
+WWW: http://pyopenssl.sourceforge.net/
diff --git a/security/py-openssl/pkg-plist b/security/py-openssl/pkg-plist
new file mode 100644
index 000000000000..ff0ca6702e8a
--- /dev/null
+++ b/security/py-openssl/pkg-plist
@@ -0,0 +1,8 @@
+lib/%%PYTHON_VERSION%%/site-packages/OpenSSL/SSL.so
+lib/%%PYTHON_VERSION%%/site-packages/OpenSSL/__init__.py
+lib/%%PYTHON_VERSION%%/site-packages/OpenSSL/__init__.pyc
+lib/%%PYTHON_VERSION%%/site-packages/OpenSSL/crypto.so
+lib/%%PYTHON_VERSION%%/site-packages/OpenSSL/rand.so
+lib/%%PYTHON_VERSION%%/site-packages/OpenSSL/tsafe.py
+lib/%%PYTHON_VERSION%%/site-packages/OpenSSL/tsafe.pyc
+@dirrm lib/%%PYTHON_VERSION%%/site-packages/OpenSSL