aboutsummaryrefslogtreecommitdiff
path: root/security/py-paramiko
diff options
context:
space:
mode:
authorSofian Brabez <sbz@FreeBSD.org>2017-09-28 11:46:42 +0000
committerSofian Brabez <sbz@FreeBSD.org>2017-09-28 11:46:42 +0000
commita5988efd006be64e04edb44dc2f7417eb2eecc76 (patch)
treed43e164a29117f6ef5dd91235df5148d0735b1b6 /security/py-paramiko
parentc447cbd1261179e60a2c50482f5857f9ccffaee9 (diff)
downloadports-a5988efd006be64e04edb44dc2f7417eb2eecc76.tar.gz
ports-a5988efd006be64e04edb44dc2f7417eb2eecc76.zip
- Update to 2.3.1
Notes
Notes: svn path=/head/; revision=450847
Diffstat (limited to 'security/py-paramiko')
-rw-r--r--security/py-paramiko/Makefile2
-rw-r--r--security/py-paramiko/distinfo6
-rw-r--r--security/py-paramiko/files/patch-paramiko_client.py44
3 files changed, 4 insertions, 48 deletions
diff --git a/security/py-paramiko/Makefile b/security/py-paramiko/Makefile
index 3946d65d2735..a44b635ef533 100644
--- a/security/py-paramiko/Makefile
+++ b/security/py-paramiko/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= paramiko
-PORTVERSION= 2.2.1
+PORTVERSION= 2.3.1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
diff --git a/security/py-paramiko/distinfo b/security/py-paramiko/distinfo
index 5ed1a8548aa2..d81b904eb4fb 100644
--- a/security/py-paramiko/distinfo
+++ b/security/py-paramiko/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1501425369
-SHA256 (paramiko-2.2.1.tar.gz) = ff94ae65379914ec3c960de731381f49092057b6dd1d24d18842ead5a2eb2277
-SIZE (paramiko-2.2.1.tar.gz) = 1205818
+TIMESTAMP = 1506598600
+SHA256 (paramiko-2.3.1.tar.gz) = fa6b4f5c9d88f27c60fd9578146ff24e99d4b9f63391ff1343305bfd766c4660
+SIZE (paramiko-2.3.1.tar.gz) = 1244407
diff --git a/security/py-paramiko/files/patch-paramiko_client.py b/security/py-paramiko/files/patch-paramiko_client.py
deleted file mode 100644
index 5d0c0f116743..000000000000
--- a/security/py-paramiko/files/patch-paramiko_client.py
+++ /dev/null
@@ -1,44 +0,0 @@
---- paramiko/client.py.orig 2017-07-30 14:38:18 UTC
-+++ paramiko/client.py
-@@ -331,6 +331,30 @@ class SSHClient (ClosingContextManager):
- t = self._transport = Transport(
- sock, gss_kex=gss_kex, gss_deleg_creds=gss_deleg_creds)
- t.use_compression(compress=compress)
-+
-+ if port == SSH_PORT:
-+ server_hostkey_name = hostname
-+ else:
-+ server_hostkey_name = "[%s]:%d" % (hostname, port)
-+
-+ # if we already have a host key stored, change our key preference
-+ known_host_keys = {}
-+ known_host_keys.update(
-+ self._system_host_keys.get(server_hostkey_name, {})
-+ )
-+ known_host_keys.update(
-+ self.get_host_keys().get(server_hostkey_name, {})
-+ )
-+
-+ if known_host_keys:
-+ # order the keys as follows: known keys in preferred-keys order,
-+ # then unknown keys in preferred-keys order
-+ valid_known_keys = [k for k in t._preferred_keys
-+ if k in known_host_keys]
-+ t._preferred_keys = (valid_known_keys
-+ + [k for k in t._preferred_keys
-+ if k not in valid_known_keys])
-+
- if gss_kex and gss_host is None:
- t.set_gss_host(hostname)
- elif gss_kex and gss_host is not None:
-@@ -344,10 +368,6 @@ class SSHClient (ClosingContextManager):
- if auth_timeout is not None:
- t.auth_timeout = auth_timeout
-
-- if port == SSH_PORT:
-- server_hostkey_name = hostname
-- else:
-- server_hostkey_name = "[%s]:%d" % (hostname, port)
- our_server_keys = None
-
- # If GSS-API Key Exchange is performed we are not required to check the