aboutsummaryrefslogtreecommitdiff
path: root/security/py-pgpy/Makefile
diff options
context:
space:
mode:
authorDanilo G. Baio <dbaio@FreeBSD.org>2020-04-25 15:39:57 +0000
committerDanilo G. Baio <dbaio@FreeBSD.org>2020-04-25 15:39:57 +0000
commit80e49d7873fe5ff1817e55a7f541d60b9bb4b153 (patch)
tree5c81c0950adab4b269e4bdf0ff2eda6dd4fea4ac /security/py-pgpy/Makefile
parent862110f54bf0398b4e8dc4c5be62131f5a44300b (diff)
downloadports-80e49d7873fe5ff1817e55a7f541d60b9bb4b153.tar.gz
ports-80e49d7873fe5ff1817e55a7f541d60b9bb4b153.zip
Notes
Diffstat (limited to 'security/py-pgpy/Makefile')
-rw-r--r--security/py-pgpy/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/security/py-pgpy/Makefile b/security/py-pgpy/Makefile
new file mode 100644
index 000000000000..a34653cf230d
--- /dev/null
+++ b/security/py-pgpy/Makefile
@@ -0,0 +1,25 @@
+# $FreeBSD$
+
+PORTNAME= pgpy
+PORTVERSION= 0.5.2
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= PGPy-${PORTVERSION}
+
+MAINTAINER= contact@evilham.com
+COMMENT= Pretty Good Privacy for Python
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cryptography>=2.6:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>=0:devel/py-pyasn1@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.9.0:devel/py-six@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>