aboutsummaryrefslogtreecommitdiff
path: root/security/py-plaso
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2015-07-25 17:09:01 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2015-07-25 17:09:01 +0000
commit836aa8d7d1e815e4b2791362d7d3989b77cfbe05 (patch)
tree808d06cc0aa90eb8f290db43788c69cb6bde19e3 /security/py-plaso
parent584922bc731025959779aeb99a1099bc7e0921b9 (diff)
downloadports-836aa8d7d1e815e4b2791362d7d3989b77cfbe05.tar.gz
ports-836aa8d7d1e815e4b2791362d7d3989b77cfbe05.zip
Update to 1.3.0
Notes
Notes: svn path=/head/; revision=392900
Diffstat (limited to 'security/py-plaso')
-rw-r--r--security/py-plaso/Makefile18
-rw-r--r--security/py-plaso/distinfo4
-rw-r--r--security/py-plaso/files/patch-plaso_output_elastic.py10
-rw-r--r--security/py-plaso/files/patch-setup.py15
4 files changed, 19 insertions, 28 deletions
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index 1088fc81439c..4f5adddfc8c1 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -2,10 +2,9 @@
# $FreeBSD$
PORTNAME= plaso
-PORTVERSION= 1.2.0
-PORTREVISION= 1
+PORTVERSION= 1.3.0
CATEGORIES= security python
-MASTER_SITES= https://googledrive.com/host/0B30H7z4S52FleW5vUHBnblJfcjg/${PORTVERSION}/final/ \
+MASTER_SITES= https://github.com/log2timeline/plaso/releases/download/${PORTVERSION}/ \
LOCAL/antoine
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -25,6 +24,7 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
libmsiecf>=a:${PORTSDIR}/devel/libmsiecf \
libolecf>=a:${PORTSDIR}/devel/libolecf \
libregf>=a:${PORTSDIR}/devel/libregf \
+ ${PYTHON_PKGNAMEPREFIX}artifacts>=0:${PORTSDIR}/security/py-artifacts \
${PYTHON_PKGNAMEPREFIX}bencode>=0:${PORTSDIR}/converters/py-bencode \
${PYTHON_PKGNAMEPREFIX}binplist>=0:${PORTSDIR}/devel/py-binplist \
${PYTHON_PKGNAMEPREFIX}construct>=0:${PORTSDIR}/devel/py-construct \
@@ -33,6 +33,7 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
${PYTHON_PKGNAMEPREFIX}dpkt>=0:${PORTSDIR}/net/py-dpkt \
${PYTHON_PKGNAMEPREFIX}ipython>=0:${PORTSDIR}/devel/ipython \
${PYTHON_PKGNAMEPREFIX}parsing>=0:${PORTSDIR}/devel/py-parsing \
+ ${PYTHON_PKGNAMEPREFIX}pefile>=0:${PORTSDIR}/devel/py-pefile \
${PYTHON_PKGNAMEPREFIX}protobuf>=0:${PORTSDIR}/devel/py-protobuf \
${PYTHON_PKGNAMEPREFIX}psutil121>=0:${PORTSDIR}/sysutils/py-psutil121 \
${PYTHON_PKGNAMEPREFIX}pyelasticsearch>=0:${PORTSDIR}/textproc/py-pyelasticsearch \
@@ -45,17 +46,6 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
USES= python:2
USE_PYTHON= distutils autoplist
-PORTDOCS= ACKNOWLEDGEMENTS AUTHORS README
-PORTEXAMPLES= *
-
-OPTIONS_DEFINE= DOCS EXAMPLES
-
-post-install:
- @${MKDIR} ${STAGEDIR}${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
- @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/extra/* ${STAGEDIR}${EXAMPLESDIR}
-
# Note: for regression tests set LANG to en_US.UTF-8
.include <bsd.port.mk>
diff --git a/security/py-plaso/distinfo b/security/py-plaso/distinfo
index 9157b0d347a2..2154d0d2794d 100644
--- a/security/py-plaso/distinfo
+++ b/security/py-plaso/distinfo
@@ -1,2 +1,2 @@
-SHA256 (plaso-1.2.0.tar.gz) = f6b073fbf967fbdc32cecae0f78ad26d4fa666e6f238304e796d8f3b5550b327
-SIZE (plaso-1.2.0.tar.gz) = 40215055
+SHA256 (plaso-1.3.0.tar.gz) = 2f73876ee716464a0593ffc92651ac6445413f15ae096f8e68193597a98db9fa
+SIZE (plaso-1.3.0.tar.gz) = 110383339
diff --git a/security/py-plaso/files/patch-plaso_output_elastic.py b/security/py-plaso/files/patch-plaso_output_elastic.py
index b722012a9dc8..8011a4a7bf93 100644
--- a/security/py-plaso/files/patch-plaso_output_elastic.py
+++ b/security/py-plaso/files/patch-plaso_output_elastic.py
@@ -1,11 +1,11 @@
---- plaso/output/elastic.py.orig 2014-12-20 17:43:35 UTC
+--- plaso/output/elastic.py.orig 2015-06-09 20:25:30 UTC
+++ plaso/output/elastic.py
-@@ -81,6 +81,8 @@ class Elastic(output.LogOutputFormatter)
- elastic_port = getattr(config, 'elastic_port', 9200)
+@@ -135,6 +135,8 @@ class ElasticSearchOutputModule(interfac
+ """
self._elastic_db = pyelasticsearch.ElasticSearch(
u'http://{0:s}:{1:d}'.format(elastic_host, elastic_port))
+ logging.getLogger('elasticsearch.trace').setLevel(logging.WARNING)
+ logging.getLogger('elasticsearch').setLevel(logging.WARNING)
- case_name = getattr(config, 'case_name', u'')
- document_type = getattr(config, 'document_type', u'')
+ def WriteEventBody(self, event_object):
+ """Writes the body of an event object to the output.
diff --git a/security/py-plaso/files/patch-setup.py b/security/py-plaso/files/patch-setup.py
index dd671697d2e3..e33453979525 100644
--- a/security/py-plaso/files/patch-setup.py
+++ b/security/py-plaso/files/patch-setup.py
@@ -1,9 +1,10 @@
---- setup.py.orig 2014-12-20 17:43:35 UTC
+--- setup.py.orig 2015-06-15 05:38:55 UTC
+++ setup.py
-@@ -119,5 +119,5 @@ setup(
- 'Programming Language :: Python',
+@@ -104,7 +104,6 @@ setup(
+ },
+ data_files=[
+ ('share/plaso', glob.glob(os.path.join('data', '*'))),
+- ('share/doc/plaso', glob.glob(os.path.join('docs', '*'))),
],
- package_dir={'plaso': 'plaso'},
-- packages=find_packages('.'),
-+ packages=find_packages('.', exclude=['test_data', 'tools']),
- )
+ # TODO: this is disabled for now since setup.py will actually try
+ # to install the depencies directly from pypi.