aboutsummaryrefslogtreecommitdiff
path: root/security/py-plaso
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-26 10:29:40 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-26 10:29:40 +0000
commitedf41c0c16910b284f2fbfe8d97561828aa04ed2 (patch)
tree1399147e84f974eb84cb1ea41b9ad871912781b9 /security/py-plaso
parent2db9a53b00983786c0e197f44bcfbb8f83f48387 (diff)
downloadports-edf41c0c16910b284f2fbfe8d97561828aa04ed2.tar.gz
ports-edf41c0c16910b284f2fbfe8d97561828aa04ed2.zip
- Switch from easy_install to install
- Use PYDISTUTILS_AUTOPLIST - Remove DOCS/EXAMPLES conditionals
Notes
Notes: svn path=/head/; revision=341160
Diffstat (limited to 'security/py-plaso')
-rw-r--r--security/py-plaso/Makefile11
-rw-r--r--security/py-plaso/files/patch-setup.py11
-rw-r--r--security/py-plaso/pkg-plist10
3 files changed, 14 insertions, 18 deletions
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index a34af287c7d7..68bdc7d78836 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -3,6 +3,7 @@
PORTNAME= plaso
PORTVERSION= 1.0.2
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= https://googledrive.com/host/0B30H7z4S52FleW5vUHBnblJfcjg/${PORTVERSION}/final/ \
LOCAL/antoine
@@ -38,8 +39,8 @@ RUN_DEPENDS= hachoir-core>=0:${PORTSDIR}/devel/hachoir-core \
${PYTHON_PKGNAMEPREFIX}yaml>=0:${PORTSDIR}/devel/py-yaml
USE_PYTHON= 2
-USE_PYDISTUTILS=easy_install
-PYDISTUTILS_PKGVERSION=${PORTVERSION}alpha
+USE_PYDISTUTILS= yes
+PYDISTUTILS_AUTOPLIST= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= ACKNOWLEDGEMENT AUTHORS
@@ -50,16 +51,10 @@ EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
OPTIONS_DEFINE= DOCS EXAMPLES
-.include <bsd.port.options.mk>
-
post-install:
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
-.endif
-.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/extra/* ${STAGEDIR}${EXAMPLESDIR}
-.endif
.include <bsd.port.mk>
diff --git a/security/py-plaso/files/patch-setup.py b/security/py-plaso/files/patch-setup.py
new file mode 100644
index 000000000000..297751a607e2
--- /dev/null
+++ b/security/py-plaso/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- ./setup.py.orig 2013-10-31 18:02:07.000000000 +0000
++++ ./setup.py 2014-01-26 09:42:25.000000000 +0000
+@@ -104,7 +104,7 @@
+ 'Programming Language :: Python',
+ ],
+ #include_package_data=True,
+- packages=find_packages('.'),
++ packages=find_packages('.', exclude=['test_data']),
+ package_data={'plaso.test_data': GetFileList('test_data', ['*'])},
+ )
+
diff --git a/security/py-plaso/pkg-plist b/security/py-plaso/pkg-plist
deleted file mode 100644
index c4c9acf0798d..000000000000
--- a/security/py-plaso/pkg-plist
+++ /dev/null
@@ -1,10 +0,0 @@
-bin/image_export.py
-bin/log2timeline.py
-bin/pinfo.py
-bin/plasm.py
-bin/plaso_extract_search_history.py
-bin/pprof.py
-bin/preg.py
-bin/pshell.py
-bin/psort.py
-%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%