aboutsummaryrefslogtreecommitdiff
path: root/security/py-pow/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-11 14:20:24 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2002-02-11 14:20:24 +0000
commit63b45c1017653defa70572dfd47ae623ad4d1f85 (patch)
treefcee6be4561c0f8e0603936cd87e244527d81e48 /security/py-pow/Makefile
parent54a14a2a75507befa64820346cf432df544727cd (diff)
downloadports-63b45c1017653defa70572dfd47ae623ad4d1f85.tar.gz
ports-63b45c1017653defa70572dfd47ae623ad4d1f85.zip
Notes
Diffstat (limited to 'security/py-pow/Makefile')
-rw-r--r--security/py-pow/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/security/py-pow/Makefile b/security/py-pow/Makefile
new file mode 100644
index 000000000000..9617de7ff0ba
--- /dev/null
+++ b/security/py-pow/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: Python OpenSSL Wrappers
+# Date created: Feb 10, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= pow
+PORTVERSION= 0.6.1
+CATEGORIES= security python
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+DISTNAME= ${PORTNAME:U}-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PYTHON= yes
+USE_OPENSSL= yes
+
+SETUP_CMD= cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} setup.py
+
+do-build:
+ @${SETUP_CMD} build
+
+do-install:
+ @${SETUP_CMD} install
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/POW.pdf ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>