aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyaxo
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-09-15 11:51:20 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-09-15 11:51:20 +0000
commit1b75711e411bb90a897e7b917ab8ae41f67951f5 (patch)
treea70d0fcad5c3282ea264d570d625f063f60b7fce /security/py-pyaxo
parentc3fc71e864aa7cf02446fd86c0cd08a486a842bd (diff)
downloadports-1b75711e411bb90a897e7b917ab8ae41f67951f5.tar.gz
ports-1b75711e411bb90a897e7b917ab8ae41f67951f5.zip
security/py-pyaxo: Add missing dependency
net-im/py-unmessage currently fails at run-time with the following error: File "/usr/local/lib/python2.7/site-packages/unmessage/cli.py", line 9, in <module> from pyaxo import b2a File "/usr/local/lib/python2.7/site-packages/pyaxo.py", line 27, in <module> import sqlite3 File "/usr/local/lib/python2.7/sqlite3/__init__.py", line 24, in <module> from dbapi2 import * File "/usr/local/lib/python2.7/sqlite3/dbapi2.py", line 28, in <module> from _sqlite3 import * ImportError: No module named _sqlite3 This change adds the appropriate and missing dependency on databases/py-sqlite3. While I'm here: - Verbosify pytest output (one test per line) and print skipped reasons, which can be very useful during QA. - Pet portlint (extra item in USES/USE_x section: "NO_ARCH".) Reported by: DanDare (via IRC, via net-im/py-unmessage) Approved by: portmgr (blanket(s): missing dependencies, ports compliance) MFH: 2019Q3
Notes
Notes: svn path=/head/; revision=512099
Diffstat (limited to 'security/py-pyaxo')
-rw-r--r--security/py-pyaxo/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/security/py-pyaxo/Makefile b/security/py-pyaxo/Makefile
index a7046c1a8ef2..d34a959a1ec2 100644
--- a/security/py-pyaxo/Makefile
+++ b/security/py-pyaxo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= pyaxo
PORTVERSION= 0.8.2
+PORTREVISION= 1
CATEGORIES= security net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,17 +15,19 @@ LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}passlib>=1.6.1:security/py-passlib@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pynacl>=1.0.1:security/py-pynacl@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}pynacl>=1.0.1:security/py-pynacl@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
USES= python:2.7
USE_PYTHON= autoplist distutils
+
NO_ARCH= yes
post-patch:
@${REINPLACE_CMD} -e "/'pytest-runner',/d" ${WRKSRC}/setup.py
do-test:
- @(cd ${WRKSRC} && ${PYTHON_CMD} -m pytest)
+ @(cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs)
.include <bsd.port.mk>