aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyaxo
diff options
context:
space:
mode:
authorRichard Gallamore <ultima@FreeBSD.org>2017-09-11 21:13:54 +0000
committerRichard Gallamore <ultima@FreeBSD.org>2017-09-11 21:13:54 +0000
commitef3e207d8d62f6f3cc32b089131978b0635e7956 (patch)
tree2e97a2161f616a6c9f709f9ead013d3fd60aa30d /security/py-pyaxo
parent7c3e218a355bbf592c1b3ce7a4fef3a6767636d8 (diff)
downloadports-ef3e207d8d62f6f3cc32b089131978b0635e7956.tar.gz
ports-ef3e207d8d62f6f3cc32b089131978b0635e7956.zip
The Double Ratchet Algorithm is a protocol (similar to OTR) that provides for
perfect forward secrecy in (a)synchronous communications. It uses triple Diffie-Hellman for authentication and ECDHE for perfect forward secrecy. The protocol is lighter and more robust than the OTR protocol - providing better forward and future secrecy, as well as deniability. The protocol was developed by Trevor Perrin and Moxie Marlinspike. Its chief use currently is in the Open Whisper Systems Signal package. WWW: https://github.com/rxcomm/pyaxo PR: 222040 Submitted by: Yuri Victorovich (maintainer) Reviewed by: lifanov (mentor), matthew (mentor), koobs, sunpoet Approved by: lifanov (mentor), matthew (mentor), koobs Differential Revision: https://reviews.freebsd.org/D12310
Notes
Notes: svn path=/head/; revision=449667
Diffstat (limited to 'security/py-pyaxo')
-rw-r--r--security/py-pyaxo/Makefile23
-rw-r--r--security/py-pyaxo/distinfo3
-rw-r--r--security/py-pyaxo/pkg-descr10
3 files changed, 36 insertions, 0 deletions
diff --git a/security/py-pyaxo/Makefile b/security/py-pyaxo/Makefile
new file mode 100644
index 000000000000..7dff2b4d57c4
--- /dev/null
+++ b/security/py-pyaxo/Makefile
@@ -0,0 +1,23 @@
+# Created by: Yuri Victorovich
+# $FreeBSD$
+
+PORTNAME= pyaxo
+PORTVERSION= 0.7.7
+CATEGORIES= security net python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= yuri@rawbw.com
+COMMENT= Python implementation of the Axolotl ratchet protocol
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}passlib>=1.6.1:security/py-passlib \
+ ${PYTHON_PKGNAMEPREFIX}pynacl>=1.0.1:security/py-pynacl
+
+USES= python:2.7
+USE_PYTHON= autoplist distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/security/py-pyaxo/distinfo b/security/py-pyaxo/distinfo
new file mode 100644
index 000000000000..a440a10e9a23
--- /dev/null
+++ b/security/py-pyaxo/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1504483719
+SHA256 (pyaxo-0.7.7.tar.gz) = f0eafd73e76fc9fa8dc403a68254b7f712a311a6208f812f27f8acc4de8aaaa1
+SIZE (pyaxo-0.7.7.tar.gz) = 63293
diff --git a/security/py-pyaxo/pkg-descr b/security/py-pyaxo/pkg-descr
new file mode 100644
index 000000000000..79908d5ef665
--- /dev/null
+++ b/security/py-pyaxo/pkg-descr
@@ -0,0 +1,10 @@
+The Double Ratchet Algorithm is a protocol (similar to OTR) that provides for
+perfect forward secrecy in (a)synchronous communications. It uses triple
+Diffie-Hellman for authentication and ECDHE for perfect forward secrecy. The
+protocol is lighter and more robust than the OTR protocol - providing better
+forward and future secrecy, as well as deniability.
+
+The protocol was developed by Trevor Perrin and Moxie Marlinspike. Its chief
+use currently is in the Open Whisper Systems Signal package.
+
+WWW: https://github.com/rxcomm/pyaxo