aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyclamd
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2009-01-09 23:24:06 +0000
committerMartin Wilke <miwi@FreeBSD.org>2009-01-09 23:24:06 +0000
commit2367e4c0e0a6bcc4206a6a6df7c4547174747ba7 (patch)
tree14a2dce31f1d35058c3be4996f95e4f41a26cbfe /security/py-pyclamd
parente2c0b5376c43b851ab9d1ecad23b1f769dde5639 (diff)
downloadports-2367e4c0e0a6bcc4206a6a6df7c4547174747ba7.tar.gz
ports-2367e4c0e0a6bcc4206a6a6df7c4547174747ba7.zip
pyClamd is a python interface to Clamd (Clamav daemon).
By using pyClamd, you can add virus detection capabilities to your python software in an efficient and easy way. PR: ports/130312 Submitted by: Milan Obuch
Notes
Notes: svn path=/head/; revision=225619
Diffstat (limited to 'security/py-pyclamd')
-rw-r--r--security/py-pyclamd/Makefile31
-rw-r--r--security/py-pyclamd/distinfo3
-rw-r--r--security/py-pyclamd/files/patch-pyclamd.py38
-rw-r--r--security/py-pyclamd/files/patch-setup.py19
-rw-r--r--security/py-pyclamd/pkg-descr3
-rw-r--r--security/py-pyclamd/pkg-plist3
6 files changed, 97 insertions, 0 deletions
diff --git a/security/py-pyclamd/Makefile b/security/py-pyclamd/Makefile
new file mode 100644
index 000000000000..28bffa80a9a8
--- /dev/null
+++ b/security/py-pyclamd/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: pyClamd
+# Date created: Jan 7, 2009
+# Whom: Milan Obuch
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyclamd
+PORTVERSION= 0.1.1
+CATEGORIES= mail python
+MASTER_SITES= http://xael.org/norman/python/pyclamd/
+DISTFILES= pyclamd.py
+
+MAINTAINER= bsd@dino.sk
+COMMENT= Python ClamD interface module
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+
+.include <bsd.port.pre.mk>
+
+do-extract:
+ @${RM} -rf ${WRKDIR}
+ @${MKDIR} ${WRKDIR}
+ @${MKDIR} ${WRKDIR}/${PKGNAME}
+ if ! (cd ${WRKDIR} && ${CP} ${DISTDIR}/${DISTFILES} ${WRKDIR}/${PKGNAME}/); \
+ then \
+ exit 1; \
+ fi; \
+
+.include <bsd.port.post.mk>
diff --git a/security/py-pyclamd/distinfo b/security/py-pyclamd/distinfo
new file mode 100644
index 000000000000..00eb05a9439e
--- /dev/null
+++ b/security/py-pyclamd/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyclamd.py) = fcdc195401e8c78a0d19ee6b8c23fdcb
+SHA256 (pyclamd.py) = 3542cc2271c8365a4205c563705a9f3090dca3f6242524119cb6560b7bbfcbaf
+SIZE (pyclamd.py) = 10498
diff --git a/security/py-pyclamd/files/patch-pyclamd.py b/security/py-pyclamd/files/patch-pyclamd.py
new file mode 100644
index 000000000000..029b4ee6c049
--- /dev/null
+++ b/security/py-pyclamd/files/patch-pyclamd.py
@@ -0,0 +1,38 @@
+--- pyclamd.py.orig 2007-04-11 18:10:26.000000000 +0200
++++ pyclamd.py 2007-08-28 11:28:48.000000000 +0200
+@@ -14,7 +14,7 @@
+ # Network
+ pyclamd.init_network_socket('localhost', 3310)
+ # Unix local socket
+- #pyclamd.init_unix_socket('/var/run/clamd')
++ #pyclamd.init_unix_socket('/var/run/clamav/clamd')
+
+ # Get Clamscan version
+ print pyclamd.version()
+@@ -29,7 +29,7 @@
+ Test strings :
+ ^^^^^^^^^^^^
+ >>> try:
+-... init_unix_socket('/var/run/clamd')
++... init_unix_socket('/var/run/clamav/clamd')
+ ... except ScanError:
+ ... init_network_socket('localhost', 3310)
+ ...
+@@ -68,7 +68,7 @@
+
+ # Default values for globals
+ use_socket = None
+-clamd_SOCKET = "/var/run/clamd"
++clamd_SOCKET = "/var/run/clamav/clamd"
+ clamd_HOST='127.0.0.1'
+ clamd_PORT=3310
+
+@@ -85,7 +85,7 @@
+
+ ############################################################################
+
+-def init_unix_socket(filename="/var/run/clamd"):
++def init_unix_socket(filename="/var/run/clamav/clamd"):
+ """
+ Init pyclamd to use clamd unix local socket
+
diff --git a/security/py-pyclamd/files/patch-setup.py b/security/py-pyclamd/files/patch-setup.py
new file mode 100644
index 000000000000..1d1dea40572d
--- /dev/null
+++ b/security/py-pyclamd/files/patch-setup.py
@@ -0,0 +1,19 @@
+--- setup.py.orig 2009-01-07 13:42:10.000000000 +0100
++++ setup.py 2009-01-07 13:42:27.000000000 +0100
+@@ -0,0 +1,16 @@
++#!/usr/bin/python
++
++import glob
++import os
++import sys
++from distutils.core import setup
++
++setup(name="pyclamd",
++ version="0.1.1",
++ description="Python ClamD module.",
++ author="Alexandre Norman",
++ author_email="norman@xael.org",
++ url="http://xael.org/norman/python/pyclamd/",
++ license="GPL",
++ packages=['']
++ )
diff --git a/security/py-pyclamd/pkg-descr b/security/py-pyclamd/pkg-descr
new file mode 100644
index 000000000000..eed312fdeeaf
--- /dev/null
+++ b/security/py-pyclamd/pkg-descr
@@ -0,0 +1,3 @@
+pyClamd is a python interface to Clamd (Clamav daemon).
+By using pyClamd, you can add virus detection capabilities
+to your python software in an efficient and easy way.
diff --git a/security/py-pyclamd/pkg-plist b/security/py-pyclamd/pkg-plist
new file mode 100644
index 000000000000..afc9252dac66
--- /dev/null
+++ b/security/py-pyclamd/pkg-plist
@@ -0,0 +1,3 @@
+%%PYTHON_SITELIBDIR%%/pyclamd.py
+%%PYTHON_SITELIBDIR%%/pyclamd.pyc
+%%PYTHON_SITELIBDIR%%/pyclamd.pyo