aboutsummaryrefslogtreecommitdiff
path: root/security/py-pycrypto
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-10-04 16:45:41 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-10-04 16:45:41 +0000
commit3aec6823ffde3d563b43bedfec9735cf0b46d4a8 (patch)
treee1830ddc758071d2b8523a134b6a6fd122cb674c /security/py-pycrypto
parent390e861c3f18f5a9444d37ce0b1fb0f4137dc282 (diff)
downloadports-3aec6823ffde3d563b43bedfec9735cf0b46d4a8.tar.gz
ports-3aec6823ffde3d563b43bedfec9735cf0b46d4a8.zip
- Make GMP OPTION'al
- Add upstream patch for test failure when built without GMP PR: 172299 Submitted by: koobs.freebsd@gmail.com
Notes
Notes: svn path=/head/; revision=305266
Diffstat (limited to 'security/py-pycrypto')
-rw-r--r--security/py-pycrypto/Makefile36
-rw-r--r--security/py-pycrypto/files/patch-lib__Crypto__SelfTest__Util__test_number.py37
-rw-r--r--security/py-pycrypto/files/patch-setup.py6
-rw-r--r--security/py-pycrypto/pkg-plist2
4 files changed, 68 insertions, 13 deletions
diff --git a/security/py-pycrypto/Makefile b/security/py-pycrypto/Makefile
index aca066696783..d54ec13ccb43 100644
--- a/security/py-pycrypto/Makefile
+++ b/security/py-pycrypto/Makefile
@@ -1,12 +1,10 @@
-# New ports collection makefile for: pycrypto
-# Date created: 25 Oct 2002
-# Whom: nbm
+# Created by: nbm
#
# $FreeBSD$
-#
PORTNAME= pycrypto
PORTVERSION= 2.6
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP \
https://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/
@@ -15,17 +13,37 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= jgh@FreeBSD.org
COMMENT= The Python Cryptography Toolkit
-USE_PYTHON= yes
-USE_PYDISTUTILS=yes
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
HAS_CONFIGURE= yes
USE_AUTOTOOLS= autoconf
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
-LIB_DEPENDS+= gmp.10:${PORTSDIR}/math/gmp
+OPTIONS_DEFINE= GMP
+OPTIONS_DEFAULT= GMP
+GMP_DESC= Use GMP for faster DSA/RSA operations
+
+OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MGMP}
+LIB_DEPENDS+= gmp:${PORTSDIR}/math/gmp
+CONFIGURE_ARGS+= --with-gmp
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+PLIST_SUB+= GMP=""
+.else
+CONFIGURE_ARGS+= --without-gmp
+PLIST_SUB+= GMP="@comment "
+.endif
pre-patch:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/setup.py
+test: build
+ cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+
+regression-test: test
+
.include <bsd.port.mk>
diff --git a/security/py-pycrypto/files/patch-lib__Crypto__SelfTest__Util__test_number.py b/security/py-pycrypto/files/patch-lib__Crypto__SelfTest__Util__test_number.py
new file mode 100644
index 000000000000..f6ed6d268da4
--- /dev/null
+++ b/security/py-pycrypto/files/patch-lib__Crypto__SelfTest__Util__test_number.py
@@ -0,0 +1,37 @@
+--- ./lib/Crypto/SelfTest/Util/test_number.py.orig 2012-10-03 16:03:52.000000000 +1000
++++ ./lib/Crypto/SelfTest/Util/test_number.py 2012-10-03 16:04:01.000000000 +1000
+@@ -276,6 +276,11 @@
+ self.assertEqual(number.size(0xa2ba40),8*3)
+ self.assertEqual(number.size(0xa2ba40ee07e3b2bd2f02ce227f36a195024486e49c19cb41bbbdfbba98b22b0e577c2eeaffa20d883a76e65e394c69d4b3c05a1e8fadda27edb2a42bc000fe888b9b32c22d15add0cd76b3e7936e19955b220dd17d4ea904b1ec102b2e4de7751222aa99151024c7cb41cc5ea21d00eeb41f7c800834d2c6e06bce3bce7ea9a5L), 1024)
+
++class FastmathTests(unittest.TestCase):
++ def setUp(self):
++ global number
++ from Crypto.Util import number
++
+ def test_negative_number_roundtrip_mpzToLongObj_longObjToMPZ(self):
+ """Test that mpzToLongObj and longObjToMPZ (internal functions) roundtrip negative numbers correctly."""
+ n = -100000000000000000000000000000000000L
+@@ -286,7 +291,21 @@
+
+ def get_tests(config={}):
+ from Crypto.SelfTest.st_common import list_test_cases
+- return list_test_cases(MiscTests)
++ tests = list_test_cases(MiscTests)
++ try:
++ from Crypto.PublicKey import _fastmath
++ tests += list_test_cases(FastmathTests)
++ except ImportError:
++ from distutils.sysconfig import get_config_var
++ import inspect, os.path
++ _fm_path = os.path.normpath(os.path.dirname(os.path.abspath(
++ inspect.getfile(inspect.currentframe())))
++ +"/../../PublicKey/_fastmath"+get_config_var("SO"))
++ if os.path.exists(_fm_path):
++ raise ImportError("While the _fastmath module exists, importing "+
++ "it failed. This may point to the gmp or mpir shared library "+
++ "not being in the path. _fastmath was found at "+_fm_path)
++ return tests
+
+ if __name__ == '__main__':
+ suite = lambda: unittest.TestSuite(get_tests())
diff --git a/security/py-pycrypto/files/patch-setup.py b/security/py-pycrypto/files/patch-setup.py
index b6a7f4f1ecfe..dc0e8867a937 100644
--- a/security/py-pycrypto/files/patch-setup.py
+++ b/security/py-pycrypto/files/patch-setup.py
@@ -1,6 +1,6 @@
---- setup.py.orig 2011-11-01 17:47:23.000000000 +0400
-+++ setup.py 2011-11-01 17:54:51.000000000 +0400
-@@ -177,6 +177,7 @@
+--- ./setup.py.orig 2012-10-03 15:57:50.000000000 +1000
++++ ./setup.py 2012-10-03 15:57:50.000000000 +1000
+@@ -136,6 +136,7 @@
# especially helps the DES modules.
self.__add_compiler_option("-O3")
self.__add_compiler_option("-fomit-frame-pointer")
diff --git a/security/py-pycrypto/pkg-plist b/security/py-pycrypto/pkg-plist
index da094a77bb94..90fb3d9ae340 100644
--- a/security/py-pycrypto/pkg-plist
+++ b/security/py-pycrypto/pkg-plist
@@ -115,7 +115,7 @@
%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/__init__.py
%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/__init__.pyc
%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/__init__.pyo
-%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/_fastmath.so
+%%GMP%%%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/_fastmath.so
%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/_slowmath.py
%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/_slowmath.pyc
%%PYTHON_SITELIBDIR%%/Crypto/PublicKey/_slowmath.pyo