aboutsummaryrefslogtreecommitdiff
path: root/security/py-pycrypto
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2014-12-23 04:52:07 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2014-12-23 04:52:07 +0000
commita47e542de52bdedcf43a0a6816d49f6a8a701654 (patch)
treee0dd3a22edaedba99afab590d61e7e417ce16ae1 /security/py-pycrypto
parent89c64b4445d8e13720bd832ebe990f3e9aae005c (diff)
downloadports-a47e542de52bdedcf43a0a6816d49f6a8a701654.tar.gz
ports-a47e542de52bdedcf43a0a6816d49f6a8a701654.zip
security/py-pycrypto: Strip shared libraries
- Strip shared libraries - Use GNU_CONFIGURE over HAS_CONFIGURE and USE_AUTOTOOLS - Give in and strip leading "The" in COMMENT - Tweak regression-test target - Update pkg-descr WWW: URL
Notes
Notes: svn path=/head/; revision=375311
Diffstat (limited to 'security/py-pycrypto')
-rw-r--r--security/py-pycrypto/Makefile12
-rw-r--r--security/py-pycrypto/pkg-descr2
2 files changed, 8 insertions, 6 deletions
diff --git a/security/py-pycrypto/Makefile b/security/py-pycrypto/Makefile
index 9e36b11bfd89..87e3bffd14d2 100644
--- a/security/py-pycrypto/Makefile
+++ b/security/py-pycrypto/Makefile
@@ -3,24 +3,23 @@
PORTNAME= pycrypto
PORTVERSION= 2.6.1
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
-COMMENT= The Python Cryptography Toolkit
+COMMENT= Python Cryptography Toolkit
USES= python
USE_PYTHON= distutils autoplist
-HAS_CONFIGURE= yes
-USE_AUTOTOOLS= autoconf
+GNU_CONFIGURE= yes
OPTIONS_DEFINE= GMP
OPTIONS_DEFAULT= GMP
GMP_DESC= Use GMP for faster DSA/RSA operations
-
GMP_CONFIGURE_WITH= gmp
GMP_CPPFLAGS= -I${LOCALBASE}/include
GMP_LDFLAGS= -L${LOCALBASE}/lib
@@ -29,7 +28,10 @@ GMP_LIB_DEPENDS= libgmp.so:${PORTSDIR}/math/gmp
pre-patch:
@${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|" ${WRKSRC}/setup.py
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/Crypto/*/*.so
+
regression-test: build
- cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
.include <bsd.port.mk>
diff --git a/security/py-pycrypto/pkg-descr b/security/py-pycrypto/pkg-descr
index 5e33edb2f313..bdd5171e2e9d 100644
--- a/security/py-pycrypto/pkg-descr
+++ b/security/py-pycrypto/pkg-descr
@@ -4,4 +4,4 @@ This is a collection of both secure hash functions (such as MD5 and
SHA), and various encryption algorithms (AES, DES, ElGamal, etc.) for
Python.
-WWW: http://pycrypto.org
+WWW: https://pycrypto.org