aboutsummaryrefslogtreecommitdiff
path: root/security/py-pycryptodome
diff options
context:
space:
mode:
authorJohn W. O'Brien <john@saltant.com>2022-08-06 22:09:54 +0000
committerNeel Chauhan <nc@FreeBSD.org>2022-08-06 22:09:54 +0000
commit8eb6a01274cf34f8bb03a28fc451a814b7fa73ed (patch)
tree6fec0a4dc4d977214ec3b9b1e73961e6b6a81aef /security/py-pycryptodome
parent8b649415766e139f692433ca603d7a3fd296f47e (diff)
downloadports-8eb6a01274cf34f8bb03a28fc451a814b7fa73ed.tar.gz
ports-8eb6a01274cf34f8bb03a28fc451a814b7fa73ed.zip
Diffstat (limited to 'security/py-pycryptodome')
-rw-r--r--security/py-pycryptodome/Makefile8
-rw-r--r--security/py-pycryptodome/distinfo6
-rw-r--r--security/py-pycryptodome/pkg-descr6
3 files changed, 12 insertions, 8 deletions
diff --git a/security/py-pycryptodome/Makefile b/security/py-pycryptodome/Makefile
index 7dc73dc403d9..e451ae2856a1 100644
--- a/security/py-pycryptodome/Makefile
+++ b/security/py-pycryptodome/Makefile
@@ -1,5 +1,5 @@
PORTNAME= pycryptodome
-DISTVERSION= 3.12.0
+DISTVERSION= 3.15.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -11,8 +11,10 @@ LICENSE= PD BSD2CLAUSE APACHE20
LICENSE_COMB= multi
LICENSE_FILE= ${WRKSRC}/LICENSE.rst
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycryptodome-test-vectors>=0:security/py-pycryptodome-test-vectors@${PY_FLAVOR}
+
# Officially: 2.7, 3.5-3.10
-USES= cpe python:3.6+ zip
+USES= cpe python:3.7+
CPE_VENDOR= python
USE_PYTHON= autoplist distutils
@@ -29,6 +31,6 @@ post-install:
@${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/${NAMESPACE}/Util/*.so
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} test
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m ${NAMESPACE}.SelfTest
.include <bsd.port.mk>
diff --git a/security/py-pycryptodome/distinfo b/security/py-pycryptodome/distinfo
index 9eeb6e33fa5b..f335eebd14cb 100644
--- a/security/py-pycryptodome/distinfo
+++ b/security/py-pycryptodome/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1640650324
-SHA256 (pycryptodome-3.12.0.zip) = 12c7343aec5a3b3df5c47265281b12b611f26ec9367b6129199d67da54b768c1
-SIZE (pycryptodome-3.12.0.zip) = 3717073
+TIMESTAMP = 1657286387
+SHA256 (pycryptodome-3.15.0.tar.gz) = 9135dddad504592bcc18b0d2d95ce86c3a5ea87ec6447ef25cfedea12d6018b8
+SIZE (pycryptodome-3.15.0.tar.gz) = 4547210
diff --git a/security/py-pycryptodome/pkg-descr b/security/py-pycryptodome/pkg-descr
index 1ac395ac2177..9658fb904c53 100644
--- a/security/py-pycryptodome/pkg-descr
+++ b/security/py-pycryptodome/pkg-descr
@@ -5,10 +5,12 @@ PyCrypto (2.6.1):
* Authenticated encryption modes (GCM, CCM, EAX, SIV, OCB)
* Accelerated AES on Intel platforms via AES-NI
* First class support for PyPy
+* Elliptic curves cryptography (NIST P-curves; Ed25519, Ed448)
+* Better and more compact API
* SHA-3 (including SHAKE XOFs) and BLAKE2 hash algorithms
* Salsa20 and ChaCha20 stream ciphers
* scrypt and HKDF
-* Deterministic DSA
+* Deterministic (EC)DSA and EdDSA
* Password-protected PKCS#8 key containers
* Shamir's Secret Sharing scheme
* Random numbers get sourced directly from the OS (and not from
@@ -17,4 +19,4 @@ PyCrypto (2.6.1):
* Cleaner RSA and DSA key generation (largely based on FIPS 186-4)
* Major clean ups and simplification of the code base
-WWW: https://www.pycryptodome.org/en/latest/
+WWW: https://www.pycryptodome.org/