aboutsummaryrefslogtreecommitdiff
path: root/security/py-python-gnupg/Makefile
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-04-17 09:30:55 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2020-04-17 09:30:55 +0000
commit796f4587e441fc0ac32c23d476b40f49d29bdaf0 (patch)
tree2ffb2263275f88a83cbd184073f342cb07623df5 /security/py-python-gnupg/Makefile
parent9aa37199261bf213752c9868b3d48ca5fac666d9 (diff)
downloadports-796f4587e441fc0ac32c23d476b40f49d29bdaf0.tar.gz
ports-796f4587e441fc0ac32c23d476b40f49d29bdaf0.zip
Notes
Diffstat (limited to 'security/py-python-gnupg/Makefile')
-rw-r--r--security/py-python-gnupg/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/security/py-python-gnupg/Makefile b/security/py-python-gnupg/Makefile
index ff2f7762c2c9..1bf403539ed7 100644
--- a/security/py-python-gnupg/Makefile
+++ b/security/py-python-gnupg/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= python-gnupg
-PORTVERSION= 0.4.3
+PORTVERSION= 0.4.5
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -13,9 +13,15 @@ COMMENT= Python wrapper for the GNU Privacy Guard (GPG or GnuPG)
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0.15.2:devel/py-coverage@${PY_FLAVOR}
+
USES= python
NO_ARCH= yes
USE_PYTHON= autoplist distutils
+do-test:
+ @(cd ${WRKSRC} && ${SETENV} ${PYTHON_CMD} test_gnupg.py --no-doctests)
+ @(cd ${WRKSRC} && ${SETENV} coverage-${PYTHON_VER} run test_gnupg.py --no-doctests)
+
.include <bsd.port.mk>