aboutsummaryrefslogtreecommitdiff
path: root/security/py-python-pkcs11
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 21:28:29 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-12-10 21:28:29 +0000
commitf0c27855bec0967a3d15186f42b1b4bcfce8ee5e (patch)
tree27cdc5a8232fd971806ccc34c36cb702742ba63d /security/py-python-pkcs11
parent36172e2f32e03a84422a956e3c8b0e2f6a712097 (diff)
downloadports-f0c27855bec0967a3d15186f42b1b4bcfce8ee5e.tar.gz
ports-f0c27855bec0967a3d15186f42b1b4bcfce8ee5e.zip
Add py-python-pkcs11 0.7.0
A high level, "more Pythonic" interface to the PKCS#11 (Cryptoki) standard to support HSM and Smartcard devices in Python. The interface is designed to follow the logical structure of a HSM, with useful defaults for obscurely documented parameters. Many APIs will optionally accept iterables and act as generators, allowing you to stream large data blocks for symmetric encryption. python-pkcs11 also includes numerous utility functions to convert between PKCS #11 data structures and common interchange formats including PKCS #1 and X.509. python-pkcs11 is fully documented and has a full integration test suite for all features, with continuous integration against multiple HSM platforms including: - Thales nCipher - Opencryptoki TPM - OpenSC/Smartcard-HSM/Nitrokey HSM WWW: https://github.com/danni/python-pkcs11
Notes
Notes: svn path=/head/; revision=557469
Diffstat (limited to 'security/py-python-pkcs11')
-rw-r--r--security/py-python-pkcs11/Makefile28
-rw-r--r--security/py-python-pkcs11/distinfo3
-rw-r--r--security/py-python-pkcs11/pkg-descr18
3 files changed, 49 insertions, 0 deletions
diff --git a/security/py-python-pkcs11/Makefile b/security/py-python-pkcs11/Makefile
new file mode 100644
index 000000000000..94b157880e96
--- /dev/null
+++ b/security/py-python-pkcs11/Makefile
@@ -0,0 +1,28 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= python-pkcs11
+PORTVERSION= 0.7.0
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= PKCS\#11 (Cryptoki) support for Python
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools_scm>=0:devel/py-setuptools_scm@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}asn1crypto>=0:devel/py-asn1crypto@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cached-property>=0:devel/py-cached-property@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= autoplist concurrent cython distutils
+
+.include <bsd.port.pre.mk>
+
+.if ${PYTHON_REL} < 3600
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}aenum>=0:devel/py-aenum@${PY_FLAVOR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/py-python-pkcs11/distinfo b/security/py-python-pkcs11/distinfo
new file mode 100644
index 000000000000..264683b9b975
--- /dev/null
+++ b/security/py-python-pkcs11/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1607539627
+SHA256 (python-pkcs11-0.7.0.tar.gz) = 9737e0c24cabb8bc9d48bf8c57c3df2a70f8cdd96b70c50290803286f9e46bf7
+SIZE (python-pkcs11-0.7.0.tar.gz) = 106517
diff --git a/security/py-python-pkcs11/pkg-descr b/security/py-python-pkcs11/pkg-descr
new file mode 100644
index 000000000000..d4a9e0eb5cbd
--- /dev/null
+++ b/security/py-python-pkcs11/pkg-descr
@@ -0,0 +1,18 @@
+A high level, "more Pythonic" interface to the PKCS#11 (Cryptoki) standard to
+support HSM and Smartcard devices in Python.
+
+The interface is designed to follow the logical structure of a HSM, with useful
+defaults for obscurely documented parameters. Many APIs will optionally accept
+iterables and act as generators, allowing you to stream large data blocks for
+symmetric encryption.
+
+python-pkcs11 also includes numerous utility functions to convert between PKCS
+#11 data structures and common interchange formats including PKCS #1 and X.509.
+
+python-pkcs11 is fully documented and has a full integration test suite for all
+features, with continuous integration against multiple HSM platforms including:
+- Thales nCipher
+- Opencryptoki TPM
+- OpenSC/Smartcard-HSM/Nitrokey HSM
+
+WWW: https://github.com/danni/python-pkcs11