aboutsummaryrefslogtreecommitdiff
path: root/security/py-python-registry
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-26 22:32:12 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2018-02-26 22:32:12 +0000
commit9415533407f0aa2267f31d67f806208593893c40 (patch)
treee70d1629a1dde2c3c84c15ed1f0fc3ca1d854bda /security/py-python-registry
parent36be8b2b2c090c87044fc267cfe175aeb7efc171 (diff)
downloadports-9415533407f0aa2267f31d67f806208593893c40.tar.gz
ports-9415533407f0aa2267f31d67f806208593893c40.zip
Simplify Makefile: use PY_ENUM34
With hat: python
Notes
Notes: svn path=/head/; revision=463082
Diffstat (limited to 'security/py-python-registry')
-rw-r--r--security/py-python-registry/Makefile10
1 files changed, 3 insertions, 7 deletions
diff --git a/security/py-python-registry/Makefile b/security/py-python-registry/Makefile
index 22e79254a6b5..1b632b3cebb8 100644
--- a/security/py-python-registry/Makefile
+++ b/security/py-python-registry/Makefile
@@ -13,6 +13,8 @@ COMMENT= Read access to Windows Registry files
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
+RUN_DEPENDS= ${PY_ENUM34}
+
USE_GITHUB= yes
GH_ACCOUNT= williballenthin
@@ -27,12 +29,6 @@ OPTIONS_DEFINE= DOCS EXAMPLES
PORTDOCS= *
PORTEXAMPLES= *
-.include <bsd.port.pre.mk>
-
-.if ${PYTHON_REL} < 3400
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}enum34>=0:devel/py-enum34@${FLAVOR}
-.endif
-
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/CHANGELOG.TXT ${WRKSRC}/CONTRIBUTORS.TXT ${WRKSRC}/README.MD \
@@ -42,4 +38,4 @@ post-install-EXAMPLES-on:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
${INSTALL_SCRIPT} ${WRKSRC}/samples/*.py ${STAGEDIR}${EXAMPLESDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>