aboutsummaryrefslogtreecommitdiff
path: root/security/py-python3-saml
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-26 17:38:09 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2021-01-26 17:38:09 +0000
commit7a746767353aed6b551a4f6a182bd81b7cf45f4d (patch)
treeea039f2078eb33abf80117ff760f9105de1d0490 /security/py-python3-saml
parent5ec7df86f749d879b3c71624773fd3b714f3b81e (diff)
downloadports-7a746767353aed6b551a4f6a182bd81b7cf45f4d.tar.gz
ports-7a746767353aed6b551a4f6a182bd81b7cf45f4d.zip
Update to 1.10.0
Notes
Notes: svn path=/head/; revision=562839
Diffstat (limited to 'security/py-python3-saml')
-rw-r--r--security/py-python3-saml/Makefile8
-rw-r--r--security/py-python3-saml/distinfo6
-rw-r--r--security/py-python3-saml/files/patch-setup.py11
3 files changed, 18 insertions, 7 deletions
diff --git a/security/py-python3-saml/Makefile b/security/py-python3-saml/Makefile
index 13c5329cadc3..2f0fe1f7d596 100644
--- a/security/py-python3-saml/Makefile
+++ b/security/py-python3-saml/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= python3-saml
-PORTVERSION= 1.9.0
-PORTREVISION= 1
+PORTVERSION= 1.10.0
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,9 +13,10 @@ COMMENT= Add SAML support to your Python software
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>=0.5.0:devel/py-defusedxml@${PY_FLAVOR} \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}defusedxml>=0.6.0:devel/py-defusedxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}isodate>=0.5.0:devel/py-isodate@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}xmlsec>=0.6.0:security/py-xmlsec@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.3.5:devel/py-lxml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}xmlsec>=1.0.5:security/py-xmlsec@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
diff --git a/security/py-python3-saml/distinfo b/security/py-python3-saml/distinfo
index f8d09debe90a..b1535a613290 100644
--- a/security/py-python3-saml/distinfo
+++ b/security/py-python3-saml/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1582888982
-SHA256 (python3-saml-1.9.0.tar.gz) = 68ca2e5591769a1a87c9aac1779ff2c0852ddc89fb0b0371f50f781d354323da
-SIZE (python3-saml-1.9.0.tar.gz) = 76331
+TIMESTAMP = 1611665501
+SHA256 (python3-saml-1.10.0.tar.gz) = 40b689fc5ee60aa59fc83356b591f1ea3ef64de7c5e040eafb4e9f5b10f45aeb
+SIZE (python3-saml-1.10.0.tar.gz) = 78773
diff --git a/security/py-python3-saml/files/patch-setup.py b/security/py-python3-saml/files/patch-setup.py
new file mode 100644
index 000000000000..f67e09d8a104
--- /dev/null
+++ b/security/py-python3-saml/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig 2021-01-14 10:34:05 UTC
++++ setup.py
+@@ -39,7 +39,7 @@ setup(
+ 'isodate>=0.5.0',
+ 'lxml>=3.3.5',
+ 'xmlsec>=1.0.5',
+- 'defusedxml==0.6.0'
++ 'defusedxml>=0.6.0'
+ ],
+ dependency_links=['http://github.com/mehcode/python-xmlsec/tarball/master'],
+ extras_require={