aboutsummaryrefslogtreecommitdiff
path: root/security/py-pyvex
diff options
context:
space:
mode:
authorMateusz Piotrowski <0mp@FreeBSD.org>2020-03-12 13:43:44 +0000
committerMateusz Piotrowski <0mp@FreeBSD.org>2020-03-12 13:43:44 +0000
commit903227db5db7c150f3f514e106904dd0d7545250 (patch)
tree0e71d0607dadb73985d35a3680ebaa14c706f42c /security/py-pyvex
parent85dabfd2a145b302831063b38e5a55e897b2a670 (diff)
downloadports-903227db5db7c150f3f514e106904dd0d7545250.tar.gz
ports-903227db5db7c150f3f514e106904dd0d7545250.zip
Do not use too strict version requirements for *_DEPENDS
Notes
Notes: svn path=/head/; revision=528292
Diffstat (limited to 'security/py-pyvex')
-rw-r--r--security/py-pyvex/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/py-pyvex/Makefile b/security/py-pyvex/Makefile
index e860fe0b8bd1..79871545a500 100644
--- a/security/py-pyvex/Makefile
+++ b/security/py-pyvex/Makefile
@@ -22,12 +22,12 @@ ONLY_FOR_ARCHS_REASON= pyvex_c/pyvex.c does not support this architecture (see l
BUILD_DEPENDS= ${_MY_DEPENDS}
RUN_DEPENDS= ${_MY_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}archinfo==${DISTVERSION}:devel/py-archinfo@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}archinfo>=${DISTVERSION}:devel/py-archinfo@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}bitstring>0:devel/py-bitstring@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}future>0:devel/py-future@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycparser>0:devel/py-pycparser@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}angr==${DISTVERSION}:security/py-angr@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}angr>=${DISTVERSION}:security/py-angr@${PY_FLAVOR} \
z3>=0:math/z3
USES= gmake localbase python:3.5+