aboutsummaryrefslogtreecommitdiff
path: root/security/py-rsa
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2017-07-16 14:57:14 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2017-07-16 14:57:14 +0000
commit9c83c8cc88fdc8fb40f2370b8d7c02b8b8c2726d (patch)
tree64bf506425ba78a9233783a6f3b4f7301306740e /security/py-rsa
parent37dd139b56f330e16e3b40de66e147248f9764de (diff)
downloadports-9c83c8cc88fdc8fb40f2370b8d7c02b8b8c2726d.tar.gz
ports-9c83c8cc88fdc8fb40f2370b8d7c02b8b8c2726d.zip
security/py-rsa: Update to 3.4.2
* Add TEST_DEPENDS (upstream uses pytest, this will use nose) * Remove setup.py patch * Update WWW (permanent redirect to https)
Notes
Notes: svn path=/head/; revision=446012
Diffstat (limited to 'security/py-rsa')
-rw-r--r--security/py-rsa/Makefile5
-rw-r--r--security/py-rsa/distinfo5
-rw-r--r--security/py-rsa/files/patch-setup.py12
-rw-r--r--security/py-rsa/pkg-descr2
4 files changed, 7 insertions, 17 deletions
diff --git a/security/py-rsa/Makefile b/security/py-rsa/Makefile
index c38547b9dc2d..05fa9300d98d 100644
--- a/security/py-rsa/Makefile
+++ b/security/py-rsa/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= rsa
-PORTVERSION= 3.3
+PORTVERSION= 3.4.2
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -14,6 +14,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyasn1>=0.1.3:devel/py-pyasn1
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose
USES= python
USE_PYTHON= autoplist distutils
@@ -21,6 +22,6 @@ USE_PYTHON= autoplist distutils
NO_ARCH= yes
do-test:
- @cd ${WRKSRC} && ${PYTHON_CMD} run_tests.py
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m nose
.include <bsd.port.mk>
diff --git a/security/py-rsa/distinfo b/security/py-rsa/distinfo
index 968de6ed220b..ee37f4db2411 100644
--- a/security/py-rsa/distinfo
+++ b/security/py-rsa/distinfo
@@ -1,2 +1,3 @@
-SHA256 (rsa-3.3.tar.gz) = 03f3d9bebad06681771016b8752a40b12f615ff32363c7aa19b3798e73ccd615
-SIZE (rsa-3.3.tar.gz) = 33449
+TIMESTAMP = 1500216181
+SHA256 (rsa-3.4.2.tar.gz) = 25df4e10c263fb88b5ace923dd84bf9aa7f5019687b5e55382ffcdb8bede9db5
+SIZE (rsa-3.4.2.tar.gz) = 40956
diff --git a/security/py-rsa/files/patch-setup.py b/security/py-rsa/files/patch-setup.py
deleted file mode 100644
index af3c4c48c51f..000000000000
--- a/security/py-rsa/files/patch-setup.py
+++ /dev/null
@@ -1,12 +0,0 @@
---- setup.py.orig 2016-01-13 08:43:51 UTC
-+++ setup.py
-@@ -42,6 +42,9 @@ setup(name='rsa',
- install_requires=[
- 'pyasn1 >= 0.1.3',
- ],
-+ tests_require=[
-+ 'unittest2',
-+ ],
- entry_points={'console_scripts': [
- 'pyrsa-priv2pub = rsa.util:private_to_public',
- 'pyrsa-keygen = rsa.cli:keygen',
diff --git a/security/py-rsa/pkg-descr b/security/py-rsa/pkg-descr
index 0c150504461b..a123d5b5a3d1 100644
--- a/security/py-rsa/pkg-descr
+++ b/security/py-rsa/pkg-descr
@@ -2,4 +2,4 @@ Python-RSA is a pure-Python RSA implementation. It supports encryption and
decryption, signing and verifying signatures, and key generation according to
PKCS#1 version 1.5.
-WWW: http://stuvel.eu/rsa
+WWW: https://stuvel.eu/rsa