aboutsummaryrefslogtreecommitdiff
path: root/security/py-securesystemslib
diff options
context:
space:
mode:
authorKubilay Kocak <koobs@FreeBSD.org>2019-05-14 09:25:30 +0000
committerKubilay Kocak <koobs@FreeBSD.org>2019-05-14 09:25:30 +0000
commit1b81a2a300987e9399053dbbfc3954394ebb0e0f (patch)
tree0d5f05b80a01c436625bf3df22edb3f18143469e /security/py-securesystemslib
parent73b0938f19f840e3192e9b47376861b60d25aa66 (diff)
downloadports-1b81a2a300987e9399053dbbfc3954394ebb0e0f.tar.gz
ports-1b81a2a300987e9399053dbbfc3954394ebb0e0f.zip
[NEW PORT] security/py-securesystemslib: Cryptographic and general-purpose routines
securesystemslib supports public-key and general-purpose cryptography, such as ECDSA, Ed25519, RSA, SHA256, SHA512, etc. Most of the cryptographic operations are performed by the cryptography and PyNaCl libraries, but verification of Ed25519 signatures can be done in pure Python. WWW: https://github.com/secure-systems-lab/securesystemslib [1] https://github.com/secure-systems-lab/securesystemslib/issues/166 [2] https://github.com/secure-systems-lab/securesystemslib/issues/167
Notes
Notes: svn path=/head/; revision=501637
Diffstat (limited to 'security/py-securesystemslib')
-rw-r--r--security/py-securesystemslib/Makefile33
-rw-r--r--security/py-securesystemslib/distinfo3
-rw-r--r--security/py-securesystemslib/pkg-descr6
3 files changed, 42 insertions, 0 deletions
diff --git a/security/py-securesystemslib/Makefile b/security/py-securesystemslib/Makefile
new file mode 100644
index 000000000000..666b61786157
--- /dev/null
+++ b/security/py-securesystemslib/Makefile
@@ -0,0 +1,33 @@
+# $FreeBSD$
+
+PORTNAME= securesystemslib
+PORTVERSION= 0.11.3
+DISTVERSIONPREFIX=v
+CATEGORIES= security python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= koobs@FreeBSD.org
+COMMENT= Cryptographic and general-purpose routines
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cryptography>=2.2.2:security/py-cryptography@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}colorama>=0.3.9:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pynacl>1.2.0:security/py-pynacl@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR}
+
+USES= python
+USE_GITHUB= yes # tests/LICENSE not included in PyPI sdist
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= secure-systems-lab
+GH_TAGNAME= 124bb05d
+
+NO_ARCH= yes
+
+do-test:
+ @cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -v -rs tests
+
+.include <bsd.port.mk>
diff --git a/security/py-securesystemslib/distinfo b/security/py-securesystemslib/distinfo
new file mode 100644
index 000000000000..af3e5543cbe9
--- /dev/null
+++ b/security/py-securesystemslib/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1557820499
+SHA256 (secure-systems-lab-securesystemslib-v0.11.3-124bb05d_GH0.tar.gz) = 1d8d4aba9afcf27e93ebe99a29929f787edcbfd7087415cc4a177310ccdaa6cc
+SIZE (secure-systems-lab-securesystemslib-v0.11.3-124bb05d_GH0.tar.gz) = 889234
diff --git a/security/py-securesystemslib/pkg-descr b/security/py-securesystemslib/pkg-descr
new file mode 100644
index 000000000000..637a54c81dcd
--- /dev/null
+++ b/security/py-securesystemslib/pkg-descr
@@ -0,0 +1,6 @@
+securesystemslib supports public-key and general-purpose cryptography, such
+as ECDSA, Ed25519, RSA, SHA256, SHA512, etc. Most of the cryptographic
+operations are performed by the cryptography and PyNaCl libraries, but
+verification of Ed25519 signatures can be done in pure Python.
+
+WWW: https://github.com/secure-systems-lab/securesystemslib